Logstash error "Missing kbn-version header"


(Poornima) #1

I am new to ELK and have installed ES 2.1.1, Kibana 4.3.1, Logstash 2.1.1 on Windows.
After running Logstash, getting error "Missing kbn-version header" .
Attached snapshot of the error seen in logstash and also in kibana.

Not able to figure out what this version header means and how to resolve it.


(Magnus B├Ąck) #2

Please show your Logstash configuration (the logstash.conf file). And next time please don't post screenshots of console windows from which you can copy/paste plain text.


(Poornima) #3

In logstash.conf, localhost port mentioned was wrong, on correcting it to 9200, started working.


(system) #4