Logstash-input-rackspace-3.0.1 plugin for Logstash 5.4

Hi,

I am trying to install this plugin running logstash-plugin install --no-verify --local /opt/logstash/plugins/logstash-input-rackspace-3.0.1.gem command, which give me the next output:

Installing logstash-input-rackspace
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "fog":
In Gemfile:
logstash-input-rackspace (= 3.0.1) java depends on
fog (= 1.20.0) java
Could not find gem 'fog (= 1.20.0) java', which is required by gem 'logstash-input-rackspace (= 3.0.1) java', in any of the sources.

I am running Logstash in a Docker container (in case this helps).

I have created a Gemfile with the gems needed and running bundle shows a successful installation and I can run and bundle info logstash-input-rackspace which shows:

It works perfectly again if I try to install it with:
_rvm install jruby _
_jruby -S gem install ./fog-1.20.0.gem _
jruby -S gem --local /opt/logstash/plugins/logstash-input-rackspace-3.0.1.gem

The command gem list fog is showing this:

*** LOCAL GEMS ***

fog (1.20.0)

And because the command logstash-plugin install does not work, if I run logstash-plugin list, the plugin does not appear on the list.

The last version of this plugin was updated on June 23, 2017 (https://rubygems.org/gems/logstash-input-rackspace/versions/3.0.1) and I believe is the right one to run with Logstash 5.4.

Any idea?

Thank you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.