Logstash jdbc plugin sql_last_value

hi all,
I am using logstash jdbc plugin as following:

input {
 jdbc {
    jdbc_driver_library => "F:\driver\sqljdbc_6.0\enu\jre8\sqljdbc42.jar"
    jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
    jdbc_connection_string => "jdbc:sqlserver://localhost:3333;databaseName=TotalTXN"
    jdbc_user => "sss"
    jdbc_password => "sss"
    schedule => "* */1 * * *"
	clean_run => "true"
    statement => "SELECT date FROM dbo.TotalTxn_Control"
	use_column_value => "true"
	tracking_column => "date"
output {
  elasticsearch { 
    hosts => [""]
    index => "mssql3-%{+yyyy.MM.dd}"
    user => "logstash_internal25"
    password => "x-pack-test-password"
  stdout { codec => rubydebug }

there are two issues:
when logstash starts, in the kibana i can see date values but in different format, the format of date in database is for example as "02/24/2019" but in kibana is as "February 24th 2019" , how can i handle this issue? I want kibana shows "02/24/2019"
based on my research, sql_last_value parameter can be used as a checkpoint to figure out about the last query. according above configuration, I want to last value of date (for example 02/24/2019) be saved in .logstash_jdbc_last_run, but just "--- 0" can be seen in it. how can i handle this issue?

it is solved.
I just delete the "clean_run" parameter

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.