Logstash Metricbeat monitoring - empty instance kibana display

I am having problems monitoring Logstash instances with Metricbeat, to be more precise the problem is with Kibana instance Node tab. Metricbeat service is running with logstash-xpack.yml properly configured, I can curl localhost:9600 and get a response from Logstash API.
First of all I get an extra "Standalone cluster" for my Logstash instance that I can live with since I only need the load graphs (tried troubleshooting this - all my versions are correct and I have only one metricbeat index and template).
The problem is with Nodes tab when selecting a particular Logstash instance, the tab is simply empty and there are console errors.


  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
  index.number_of_shards: 1
  index.codec: best_compression

  host: "http://x.x.x.11:5601"

  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

Cluster menu:

Selected "Standalone cluster":

Selected Logstash instance:

The overview tab works fine but it displays only input,emit and latency for all the nodes combined, I need everything else that was once available when you would select the node.
I have tried restarting my whole ES cluster, re-creating Metricbeat index, restarting Metricbeat and Kibana services, there are no errors in logs. The version is 7.11.1. Any help would be appreciated, thank you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.