Logstash not monitored by metricbeat


Still learning the set up of elastic stack, I am now stuck with metricbeat failing to register my logstash node on Kibana. However I could successfully register and monitor Elasticsearch and Kibana using metricbeat. Only stuck with Logstash.

Here is how my metricbeat monitor page looks like:

As you could see Logstash node is not detected. I followed the set up steps mentioned in the stack monitoring setup page, but in vain.

Here is my logstash.yml file:

pipeline.batch.size: 125

  • pipeline.batch.delay: 5*
  • node.name: dlmlogstash*
    path.data: /var/lib/logstash
  • pipeline.id: main*
  • pipeline.workers: 2*

log.level: info
path.logs: /var/log/logstash
xpack.monitoring.enabled: true
xpack.monitoring.Elasticsearch.username: elastic
xpack.monitoring.Elasticsearch.password: passwd
xpack.monitoring.Elasticsearch.hosts: ["http://xx.xx.xx.xx:9200"]


Here are my metricbeat set ups:



  • path: ${path.config}/modules.d/.yml
  • reload.enabled: true*
  • reload.period: 10s*


  • index.number_of_shards: 1*
  • index.codec: best_compression*

name: ldxxxxx


  • host: "xx.xx.xx.xx:5601"*


  • hosts: ["xx.xx.xx.xx:9200"]*
  • protocol: "http"*
  • username: "elastic"*
  • password: "passwd"*


    • add_host_metadata: ~*
    • add_cloud_metadata: ~*
    • add_docker_metadata: ~*
    • add_kubernetes_metadata: ~*

logging.level: info

logging.selectors: [""]*

logging.to_files: true

  • path: /var/log/metricbeat*
  • name: metricbeat*
  • keepfiles: 7*
  • permissions: 0644*

monitoring.enabled: true


# Module: logstash
# Docs: Logstash module | Metricbeat Reference [master] | Elastic

- module: logstash

  • xpack.enabled: true*
  • period: 10s*
  • hosts: ["xx.xx.xx.xx:9600"]*
  • username: "elastic"*
  • password: "passwd"*

Could you please guide me as to where I should focus in order to rectify this?

Thanks and regards,
Ashiq Aboo Backer

Within the logstash.yml file, try changing "xpack.monitoring.enabled: true" to "xpack.monitoring.enabled: false".

I believe that setting is for legacy collection (not metricbeat collection).

Thank you, but this did not fix the issue.

I have disabled xpack monitoring in logstash.yml file.

Also i followed all steps listed in Collect Logstash monitoring data with Metricbeat | Logstash Reference [8.1] | Elastic

However this doesn't fix my problem.

In fact, my Kibana cluster overview does not show any Logstash nodes!

Is there anything else I should look at?

Thanks and regards,
Ashiq Aboo Backer

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.