Logstash monitoring info not showing in kibana

i am using ELK version 6.5.4.

what i did , i changed elastic cluster settings and added as persistent
xpack.monitoring.collection.enabled : true

i changed logstash.yml file as

xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch.url: ["http://localhost:9200"]
xpack.monitoring.collection.interval: 10s
xpack.monitoring.collection.pipeline.details.enabled: true

added elastic url in kibana. Now in monitoring option, it only show elasticsearch details
It is not showing logstash

i am not using any ssl settings or security features.

Hi @varun1992,

A few things to check:

  1. How do you have monitoring configured? Are you sending monitoring data to a separate cluster or do you have a more monolith setup? If you are, double check that the exporters are setup correctly. You can read more about this here

  2. Run this query against the ES cluster you are sending monitoring data to:

POST .monitoring-logstash-6-*/_search
  "size": 1,
  "query": {
    "bool": {
      "filter": [
          "range": {
            "timestamp": {
              "gte": "now-2m",
              "lte": "now"
  1. Do you have pipelines setup and are they working correctly?

Only showing .monitoring-Kibana* and .monitoring-es*

what to do ?

Have you tried going through these steps? https://www.elastic.co/guide/en/logstash/current/logstash-monitoring-overview.html

Try restarting your elk stack

i tried it , no change

If you start logstash with --verbose, you shoudl see lines such as:

[2019-03-07T09:14:07,023][INFO ][logstash.monitoring.internalpipelinesource] Monitoring License OK
[2019-03-07T09:14:07,024][INFO ][logstash.monitoring.internalpipelinesource] Validated license for monitoring. Enabling monitoring pipeline.
[2019-03-07T09:14:11,247][INFO ][logstash.javapipeline    ] Pipeline started {"pipeline.id"=>".monitoring-logstash"}

Can you confirm that you're seeing monitoring actually start when you start the Logstash process with verbose logging enabled?

i am not seeing these lines, why is that ?

Are you certain that you are editing the correct configuration file? You could try to ensure this by pointing logstash directly to it with -f as in logstash -f /path/to/logstash.yml.

yes i edited /etc/logstash/logstash.yml file in ubuntu 18.04

Could you please post the output of logstash --log.level=debug --config.debug|egrep 'logstash.runner' but REMOVE ANY PASSWORDS OR SENSITIVE INFORMATION. Thanks!

is your logstash on the same host as ELK?
you post your data to localhost.

logstash and elastic are in different servers. beat data is indexing ok to elastic from logstash, but monitoring data not indexing

i am using a ubuntu server, it is throwing error when running this code

log is sending to different server

"xpack.monitoring.elasticsearch.url " is localhost. you should point to your elk instead of localhost

i changed it. still not working

Hi @varun1992,

Similar to @Mike_Place's suggestion above, could you please post the output of logstash --log.level=debug. The first 50 lines or so should be sufficient. As before, please REMOVE ANY PASSWORDS OR SENSITIVE INFORMATION. Thanks!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.