Logstash monitoring pipeline and SSL verification


#1

Hi All,

I'm wondering if it is possible to disable SSL certificate verification by LS v.5.6.2 completely?
with the following settings:

xpack.monitoring.elasticsearch.url: ["https://es-node"]
xpack.monitoring.elasticsearch.ssl.verification_mode: none
xpack.monitoring.collection.interval: 10s
xpack.monitoring.elasticsearch.username: "elastic"
xpack.monitoring.elasticsearch.password: "changeme"

the monitoring cannot start:

[2017-10-03T20:06:55,430][INFO ][logstash.pipeline        ] Starting pipeline {"id"=>".monitoring-logstash", "pipeline.workers"=>1, "pipeline.batch.size"=>2, "pipeline.batch.delay"=>30000, "pipeline.max_inflight"=>2}
[2017-10-03T20:07:01,311][INFO ][logstash.pipeline        ] Pipeline .monitoring-logstash started
[2017-10-03T20:07:05,118][INFO ][logstash.pipeline        ] Pipeline main started
[2017-10-03T20:07:05,205][INFO ][logstash.agent           ] Successfully started Logstash API endpoint {:port=>9600}
[2017-10-03T20:07:11,315][ERROR][logstash.inputs.metrics  ] Monitoring is not available: License information is currently unavailable. Please make sure you have added your production elasticsearch connection info in the xpack.monitoring.elasticsearch settings.

and no monitoring stats in ES :frowning:
Any hints are much appreciated! Thanks!


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.