Xpack Monitoring Pipeline: You have enabled encryption but DISABLED certificate verification

I'm seeing the below in Logstash output when it starts up for the monitoring pipeline:

[INFO ] 2019-01-31 14:16:49.047 [Converge PipelineAction::Create<.monitoring-logstash>] pipeline - Starting pipeline {:pipeline_id=>".monitoring-logstash", "pipeline.workers"=>1, "pipeline.batch.size"=>2, "pipeline.batch.delay"=>50}
[WARN ] 2019-01-31 14:16:49.049 [[.monitoring-logstash]-pipeline-manager] elasticsearch - ** WARNING ** Detected UNSAFE options in elasticsearch output configuration!
** WARNING ** You have enabled encryption but DISABLED certificate verification.
** WARNING ** To make sure your data is secure change :ssl_certificate_verification to true

This pipeline is set up by Logstash and from the Xpack settings I have configured I don't see why SSL verification would be disabled:


xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch.url: https://search.elastic.company.tld:443
xpack.monitoring.elasticsearch.username: "elastic"
xpack.monitoring.elasticsearch.password: "${ES_PASSWORD}"
xpack.monitoring.elasticsearch.ssl.ca: "/usr/share/logstash/config/letsencrypt.pem"

These warnings only appear for the monitoring pipeline, are custom processing pipelines all seem OK. Any pointers would be appreciated, I can't find any options to control certificate verification for Xpack pipelines here: https://www.elastic.co/guide/en/logstash/6.x/configuring-logstash.html#configuring-logstash


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.