Logstash not creating index in Kiabana or Eleastic Search


(Jagadeesh Koka) #1

how to make sure logstash is actually sending data to elastic search, after following a getting start guide filebeat->logstash->elasticsearch->kiabana
Logstash configuration
# Sample Logstash configuration for creating a simple

Beats -> Logstash -> Elasticsearch pipeline.

  input {
    beats {
       port => 5044
     }
 }
filter {
  json {
     source => "message"
    }
 date {
match => ["message.timestamp", "UNIX_MS", "UNIX"]
target => "@timestamp"
  }

 }  
 output {
    elasticsearch {
      hosts => ["http://localhost:9200"]
     index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
    #user => "elastic"
    #password => "changeme"
}
  stdout { codec => json }
}

All I can see in my logstash log files

[2019-04-16T17:26:25,052][INFO ][logstash.runner          ] Starting Logstash 
         {"logstash.version"=>"7.0.0"}
[2019-04-16T17:26:36,093][INFO ][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://localhost:9200/]}}
[2019-04-16T17:26:36,426][WARN ][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=>"http://localhost:9200/"}
[2019-04-16T17:26:36,510][INFO ][logstash.outputs.elasticsearch] ES Output version determined {:es_version=>7}
[2019-04-16T17:26:36,516][WARN ][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document _type {:es_version=>7}
[2019-04-16T17:26:36,558][INFO ][logstash.outputs.elasticsearch] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=> 
["http://localhost:9200"]}
[2019-04-16T17:26:36,572][INFO ][logstash.outputs.elasticsearch] Using default mapping template
[2019-04-16T17:26:36,611][INFO ][logstash.javapipeline    ] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>8, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>1000, :thread=>"#<Thread:0x2c8c65a1 run>"}
[2019-04-16T17:26:36,825][INFO ][logstash.outputs.elasticsearch] Attempting to install template {:manage_template=>{"index_patterns"=>"logstash-*", "version"=>60001, "settings"=>{"index.refresh_interval"=>"5s", "number_of_shards"=>1, "index.lifecycle.name"=>"logstash-policy", "index.lifecycle.rollover_alias"=>"logstash"}, "mappings"=>{"dynamic_templates"=>[{"message_field"=>{"path_match"=>"message", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false}}}, {"string_fields"=>{"match"=>"*", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false, "fields"=>{"keyword"=>{"type"=>"keyword", "ignore_above"=>256}}}}}], "properties"=>{"@timestamp"=>{"type"=>"date"}, "@version"=>{"type"=>"keyword"}, "geoip"=>{"dynamic"=>true, "properties"=>{"ip"=>{"type"=>"ip"}, "location"=>{"type"=>"geo_point"}, "latitude"=>{"type"=>"half_float"}, "longitude"=>{"type"=>"half_float"}}}}}}}
[2019-04-16T17:26:40,606][INFO ][logstash.inputs.beats    ] Beats inputs: Starting input listener {:address=>"0.0.0.0:5044"}
[2019-04-16T17:26:40,621][INFO ][logstash.javapipeline    ] Pipeline started {"pipeline.id"=>"main"}
[2019-04-16T17:26:40,750][INFO ][logstash.agent           ] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>[]}
[2019-04-16T17:26:40,783][INFO ][org.logstash.beats.Server] Starting server on port: 5044
[2019-04-16T17:26:41,326][INFO ][logstash.agent           ] Successfully started Logstash API endpoint {:port=>9600}

All I can see in Kiabana is filebeat index is it proabably I have loaded filebeat template manually ?

I have started logstash using this command logstash -f logstas-sample.conf