Logstash not showing any output to console, hangs on launch (on openstack VM)


(Garrett Huff) #1

Hey everyone,
I have been following the install process on logstash's getting started guide. It is very strange, on my linux machine it works perfectly fine using either the executable or the debian service. I have spun up a new Ubuntu cloud server VM (14.04) and installed the Java 1.8 JDK. Neither the service or executable works, although elasticsearch and Kibana work perfectly. If I start the service, it says that it is started however I do not see the ports listening when running netstat -tlpn. If i run the executable, it just hangs (even with the --debug switch). One thing to note is that when running the executable, I can even supply parameters that are incorrect which should at least make the code fail, however it still hangs. The executable version im using is 5.2.2 and the service I have tried is 5.4. I can not get any output at all, and the service does not create the log files which makes me think that neither are executing or starting. Anyone have any ideas?


(Magnus Bäck) #2

Lack of entropy? I don't recall the details but it has been discussed here before.


(Garrett Huff) #3

[quote="magnusbaeck, post:2, topic:85139"]
Lack of entropy?[/quote]

Can you explain what you mean by that?


(Magnus Bäck) #4

Googling "logstash lack of entropy" lead me here: https://github.com/elastic/logstash/issues/6117


(Garrett Huff) #5

Thank you! This link lead me to the answer which was doing sudo apt-get install haveged


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.