Logstash pipeline.yml error

I've one logstash pipeline.which is given in pipeline.yml.
but when i run bin/logstash.bat command in powershell i'm getting error
which is look like this

 ERROR: Failed to read pipelines yaml file. Location: D:/Elastic/logstash-7.9.2/config/pipelines.yml usage:   bin/logstash
    -f CONFIG_PATH [-t] [-r] [] [-w COUNT] [-l LOG]   bin/logstash --modules MODULE_NAME [-M "MODULE_NAME.var.PLUGIN_TYPE.PLUGIN_NAME.VARIABLE_NAME=VALUE"] [-t] [-w COUNT] [-l LOG]   bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]   bin/logstash
    -i SHELL [--log.level fatal|error|warn|info|debug|trace]   bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]   bin/logstash --help [2020-10-08T18:11:20,482][ERROR][org.logstash.Logstash    ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

pipeline.yml

   -  pipeline.id : myPipe1
      pipeline.workers :2
      pipeline.batch.size: 2
      path.config:"D:\Elastic\logstash-7.9.2\third-pipeline.conf"

What i'm doing wrong? and how to solve this?

May be It helps to avoid the aditional spaces spaces between the keys and the ":" character

   -  pipeline.id: myPipe1
      pipeline.workers: 2
      pipeline.batch.size: 2
      path.config: "D:\Elastic\logstash-7.9.2\third-pipeline.conf"

I tried but it don't work

filename issues? pipelines.yml vs pipeline.yml, It should be pipelines.yml

I don't think this is file issue. you can see different file name.

Single backslash \ is treated as an escape character,
please try to use double backslash \\ instead of single back slash \ in your path to see if that will work.

nothing change.same error getting.

Just wanted to check again, as what @humartinez said,
Inside your D:/Elastic/logstash-7.9.2/config/ , the pipeline file named
pipelines.yml or pipeline.yml it makes a different.

and pipeline.yml should be like this

   -  pipeline.id: myPipe1
      pipeline.workers: 2
      pipeline.batch.size: 2
      path.config: "D:\\Elastic\\logstash-7.9.2\\third-pipeline.conf"

If it still doesnt work, please share some debug log with
bin/logstash.bat --log.level debug --config.debug

its working just a space problem like what @humartinez said and used \\ back slash together it works.
Thank you so much both of you @humartinez @kavierkoo