Logstash RSS plugin failed to load after fresh install


i've an issue with a fresh logstash installation and logstash-input-rss plugin. when trying to test the configuration for a simple RSS reader for just 1 URL i got this error:

[DEBUG] 2023-10-29 19:57:25.354 [Converge PipelineAction::Create] registry - Tried to load a plugin's code, but failed. {:exception=>#<LoadError: no such file to load -- rss>, :path=>"rss", :type=>"input", :name=>"rss"}
[ERROR] 2023-10-29 19:57:25.397 [Converge PipelineAction::Create] registry - Unable to load plugin. {:type=>"input", :name=>"rss"}
[DEBUG] 2023-10-29 19:57:25.398 [Converge PipelineAction::Create] registry - Problems loading the plugin with {:type=>"input", :name=>"rss"}
[ERROR] 2023-10-29 19:57:25.403 [Converge PipelineAction::Create] agent - Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"Java::JavaLang::IllegalStateException", :message=>"Unable to configure plugins: (PluginLoadingError) Couldn't find any input plugin named 'rss'. Are you sure this is correct? Trying to load the rss input plugin resulted in this error: Unable to load the requested plugin named rss of type input. The plugin is not installed."

i tried many times to understand what is the issue but I'm sure it was working in previous versions.

Is the new logstash version not comnpitable with the old rss-plugin version 3.0.5 ?

what is the issue and why the logstash can't load the plugin code ? can we fix this ?

The logstash package does not bundle all the plugins that exist. It does not install rss by default. The documentation covers the simple procedure to fix this.

Thanks Badger for your response, I'm sorry that i didn't mention that i know how to install the plugin, and already i installed the plugin because i mentioned the version.
So the plugin is installed with the latest version 3.0.5 and located here:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.