Logstash service started but no input


I have tested Logstash with debug, every thing worked fine. Also tried to start logstash with /usr/share/logstash/bin/logstash and it worked. I have changed the logstash.service file to use pipeline because it worked manually, but when I start the service, i see in Kafka and Kibana that Logstash do not use input.
I don't know why it is not working when start the service and work when I start it manually.
To use the pipeline.yml, I have create a link in /usr/share/logstash/config and should work, I have tested it.
Here is the logstash.service file


# Load env vars from /etc/default/ and /etc/sysconfig/ if they exist.
# Prefixing the path with '-' makes it try to load, but if the file doesn't
# exist, it continues onward.

# When stopping, how long to wait before giving up and sending SIGKILL?
# Keep in mind that SIGKILL on a process can cause data loss.


If you have some advices, I would be happy to try them

Thank you

Hi @CemG

to install Logstash, you used rpm or deb ?

by default, the Logstash config files are under the path /etc/logstsh , and as best practice we don't modify the pipeline.yml , and we put our pipelines on .conf files under /etc/logstash/conf.d/
so when you start the Logstash service it will read automatically the pipelines you put in the path /etc/logstash/conf.d/

Hi @ibra_013
I am using Deb
I have solved the issue, it was because all my files was owned by root user and group user, so I just commented User and Group in logstash.service.
Thank you for your information, it is good to know a better way to configure Logstash.

Have a nice day,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.