Logstash.service: Unit not found (CentOS 7)


(Weyder Ferreira) #1

Hi everyone,
I'm having trouble starting Logstash in my Centos 7. I found several articles on Web, but not found a solution.

My configs:

Oracle Java 8

$ echo $JAVA_HOME
$ /usr/bin/java

$java -version
java version "1.8.0_172"
Java(TM) SE Runtime Environment (build 1.8.0_172-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.172-b11, mixed mode)

I installed the Logstash by yum following this article: https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-centos-7

But when run:

$ systemctl start logstash
Failed to start logstash.service: Unit not found

I try start manually Logstash:
$/usr/share/logstash/bin/logstash
WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
ERROR: Failed to read pipelines yaml file. Location: /usr/share/logstash/config/pipelines.yml
usage:
bin/logstash -f CONFIG_PATH [-t] [-r] [] [-w COUNT] [-l LOG]
bin/logstash --modules MODULE_NAME [-M "MODULE_NAME.var.PLUGIN_TYPE.PLUGIN_NAME.VARIABLE_NAME=VALUE"] [-t] [-w COUNT] [-l LOG]
bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]
bin/logstash --help
[ERROR] 2018-07-03 16:43:51.955 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Someone can help?


(Magnus Kessler) #2

Centos 7 uses systemd, but the post-installation script of the logstash package erroneously tries to generate an upstart script, IIRC.

You can generate the logstash.service file for systemd with

sudo /usr/share/logstash/bin/system-install /etc/logstash/startup.options systemd`

(Weyder Ferreira) #3

Exactly, after running /usr/share/logstash/bin/system-install work for me.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.