Logstash support snmptrap v3?

Hello.

Does snmptrap input plugin for logstash support v3?

The official documentation does not specify the supported versions.
Someone is asking the same question here, but there is no answer.

Thank you.

I think (I could be wrong) that logstash uses the hallidave ruby-snmp library to do all the SNMP processing. I see no indication that that library supports V3.

If it uses some other library then it will depend on whether that library supports V3. logstash does not do any SNMP processing itself.