Snmptrap for v3

Hi Team,

how can I enable snmptrap plugins for v3. The configuration I am going through applicable only for snmpv1 and v2. But my requirement is for v3 also. please guide me.

Below is my configuration:
input{
snmptrap {
community => "public"
host => "0.0.0.0"
port => 1162
type => "snmptrap"
ecs_compatibility => disabled
}
}

Can anyone pls update feasibility from logstash?