Logstash ( ver. 6.5.3 ) keep writing logs in /var/log/messages


I find an issue in logstash regarding internal logging mechanism. For some reason logstash keep writing logs in journal , /var/log/messages & /var/log/logstash/logstash-plain.log (i am using centos 7 system ) . Already check my pipelines and none of them has stdout option enabled.

My case here is that i don't want the logstash to write logs in /var/log/messages. The only way to achieve this is to add the following line in /etc/rsyslog.conf :

if $programname == 'logstash' then stop

Is there any better approach to that ?i don't want to mess around with custom options in rsyslog.conf file.

Thanks in advance!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.