Logstash won't execute unless i delete hsperfdata_root in tmp folder

Hello guys , lately i've had a problem with logstash not executing correctly , so the first time it happend i've found that the cause of the problem was that i did not have enough space in my disk so i freed um some space but the problem persists , so i tried deleting all files in tmp directory and it worked once , and i was bach to the same eroor again , so i went to tmp directory and deleted hsperfdata_root which was the only folder and it worked again , everytime i delete that folder it works !!! any idea how to deal with this problem :frowning: , i'm really stuck here , any guidance would be appreciated .

logstash version 7.4.0

Thanks in advance

Could you check the permission of the hsperfdata_root folder and the all items in this folder the next time and share it with us?
Not sure, but maybe ist a permission problem on this folder.
Are you using a linux? If yes, you could also check the syslog, maybe you can find some hints.


@KoettingSimon thanks for your answer, so the tmp directory has all the permissions so i don't think that's what causing the problem , and i got another problem now :frowning:

any idea ?

How many space do you have free in /tmp ? Could you share the output of df -h ? There are some other threads with this problem and it was the space problem.
Otherwise i would try with reinstalling logstash completly as its partly recommend in the first error,
save the config files and try to purge logstash and reinstall it, if possible.

1 Like

yes you're right it's a space problem !! it works now :smiley:
Thank you so much

Hi @haythem, great!
Please consider to mark the comment as solution in this post, so other user can faster find the solution for the problem.


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.