Logstash Yum Repo down?


(William Weerts) #1

I am trying to install logstash from the yum repo.

Instructions say to point at https://artifacts.elastic.co/packages/5.3/yum. This does not seem to be available when you go to the URL. When running the yum command I get this output:

One of the configured repositories failed (Elastic repository for 5.3 packages),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:
.
.
.
failure: repodata/repomd.xml from logstash-5.3: [Errno 256] No more mirrors to try.
https://artifacts.elastic.co/packages/5.3/yum/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

I followed this:
rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch
Add the following in your /etc/yum.repos.d/ directory in a file with a .repo suffix, for example logstash.repo
[logstash-5.3]
name=Elastic repository for 5.3 packages
baseurl=https://artifacts.elastic.co/packages/5.3/yum
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch
enabled=1
autorefresh=1
type=rpm-md

Any idea if the repo is down or am I doing something wrong?


(Aaron Mildenstein) #2

It's a new release day. We just published 5.4.0. It's entirely possible that you hit the repo at the exact moment we were uploading new files, so the xml file was missing.

Try again and see whether that's the case.


(Scot) #3

None of the keys seem to work.
curl https://artifacts.elastic.co/packages/5.3/yum/repodata/repomd.xml

<?xml version="1.0" encoding="UTF-8"?>

NoSuchKeyThe specified key does not exist.packages/5.3/yum/repodata/repomd.xml4B616F0757A26A594hAzxVG5b96aP75hUwM/IbpDCsGaJl94jQFoWWRQ1sQtHz2hy/0NK2H/fgpvKvCUU41QkgY4gSU=


(Aaron Mildenstein) #4

Instead of 5.3, try 5.x


(Scot) #5

Yep 5.4 install is wrong or not working as expected.
https://www.elastic.co/guide/en/logstash/5.4/installing-logstash.html
Use: logstash.repo
[logstash-5.x]
name=Elastic repository for 5.x packages
baseurl=https://artifacts.elastic.co/packages/5.x/yum
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch
enabled=1
autorefresh=1
type=rpm-md


(Aaron Mildenstein) #6

Curious. I upgraded yesterday with 5.x as the path. No issues whatsoever.


(Aaron Mildenstein) #7

I will spin up a vm and test this when I am able.


(Aleksandr Alekseev) #8

Hi all,

I have the same issue. Has anyone found a solution?


(Aaron Mildenstein) #9

So far as I can tell, this may be a documentation error. If you look at the documentation for 5.2, you'll see that the repository path was 5.x. If you change your repository paths to 5.x, it works as expected.

I've raised the issue with our tech docs people.


(Aaron Mildenstein) #10

If I change it to this:

$ cat /etc/yum.repos.d/logstash.repo
[logstash-5.x]
name=Elastic repository for 5.x packages
baseurl=https://artifacts.elastic.co/packages/5.x/yum
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch
enabled=1
autorefresh=1

...this is the result:

$ yum --showduplicates list logstash | expand
Available Packages
logstash.noarch                      1:5.0.0-1                      logstash-5.x
logstash.noarch                      1:5.0.1-1                      logstash-5.x
logstash.noarch                      1:5.0.2-1                      logstash-5.x
logstash.noarch                      1:5.1.1-1                      logstash-5.x
logstash.noarch                      1:5.1.2-1                      logstash-5.x
logstash.noarch                      1:5.2.0-1                      logstash-5.x
logstash.noarch                      1:5.2.1-1                      logstash-5.x
logstash.noarch                      1:5.2.2-1                      logstash-5.x
logstash.noarch                      1:5.3.0-1                      logstash-5.x
logstash.noarch                      1:5.3.1-1                      logstash-5.x
logstash.noarch                      1:5.3.2-1                      logstash-5.x
logstash.noarch                      1:5.4.0-1                      logstash-5.x

(Aleksandr Alekseev) #11

Thx for fast replay. Now everything works. I used the documentation for 5.2.


(Aaron Mildenstein) #12

The documentation for 5.3 and 5.4 are updated to now show the path as 5.x again. Thanks for reporting the issue.


(William Weerts) #13

Thank you very much for the assistance! I really appreciate it.


(system) #14

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.