LS_USER and LS_GROUP options not working

I configured LS_USER="root" and LS_GROUP="root" parameters in two places "etc/default/logstash" and "etc/logstash/startup.options". When I start with command "sudo service logstash start" it is starting with logstash user.

The reason I am changing this is it is difficult to give file permissions to all log files which are necessary. So i thought of starting logstash as root so that it can have access to all of them.

Can anyone please suggest alternatives or better solutions?


try just adding to the end of your etc/default/logstash I think this is how I solved a similar issue


@eperry It didn't work for me. Any other solution you have?

I will check my config today, I know I ran in to this,

Just for a sanity check, how did you install logstash, version and what Linux distribution?

Thanks @eperry

I installed logstash through apt-get sources and I am using Ubuntu 14.04 LTS, am using latest logstash 5.3.0

ok, will have to check, my fix was for rhel but I may be able to recreate it on my desktop

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.