Manticore::ResolutionFailure when connecting with Logstash 2.0 to Found Elasticsearch


(Constantin Stropsa) #1

Hi,

I'm trying to connect to the Found Elasticsearch server using logstash 2.0 but got this error

bin/logstash -f test.conf
io/console not supported; tty will not be manipulated
Default settings used: Filter workers: 2
←[31mFailed to install template: {:template_overwrite=>false, :template_name=>"logstash", :exception=>#<Manticore::ResolutionFailure: https>, :level=>:error}←[0m
Logstash startup completed

My configuration is simple and looks as below:

input {
	http {
		 port => 8080 
		codec => "json"
	}
}

output {
	elasticsearch {
		   hosts => ["https://be5afbb....aws.found.io:9243"] <-- i did not include the full address here
		     ssl => true
	}
	stdout {codec => json}
}

Is there anything additional I have to add to this config? I tried both with HTTP ans HTTPS (ssl enabled) - with same result
I also tried to see what happen behind using the '-verbose' and '--debug' arguments all's fine - except the connection error


(Magnus Bäck) #2

As documented, the hosts option should list hostnames or hostname:port combos, not full URLs.


(Constantin Stropsa) #3

Thanks! It works now


(system) #4