Mapper-Attachments doesn't work


(valerio) #1

Hi David i've created a new thread.

I cannot figure out how to install attachment plugin on ES 2.3.4 on windows platform.

I've tried:

1)C:\Users\uibm>C:\Users\uibm\Desktop\elasticsearch-2.3.4\bin\plugin.bat install m
apper-attachments
-> Installing mapper-attachments...
Trying https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugi
n/mapper-attachments/2.3.4/mapper-attachments-2.3.4.zip ...
ERROR: failed to download out of all possible locations..., use --verbose to get
detailed information

It's not very clear to me what is the alternative way to install the plugin

Rgds
valerio


(valerio) #2

Hi

i've downloeaded the latest mapping-attachmnet version from the link:
https://github.com/elastic/elasticsearch-mapper-attachments/, unziipped the source file, renamed mapping-attachemnts and copied under ther the es folder /plugins but when i run es i get the following error:

C:\Users\uibm>C:\Users\uibm\Desktop\elasticsearch-2.3.4\bin\elasticsearch.bat
[2016-08-16 09:23:45,463][WARN ][bootstrap ] jvm uses the client
vm, make sure to run java with the server vm for best performance by adding - server to the command line
[2016-08-16 09:23:45,623][INFO ][node ] [Karkas] version[2.3
.4], pid[5928], build[e455fd0/2016-06-30T11:24:31Z]
[2016-08-16 09:23:45,623][INFO ][node ] [Karkas] initializin
g ...
Exception in thread "main" java.lang.IllegalArgumentException: Plugin [mapping-a
ttachments] is a site plugin but has no '_site/' directory
at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.ja
va:136)
at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsServ
ice.java:378)
at org.elasticsearch.plugins.PluginsService.(PluginsService.java:1
28)
at org.elasticsearch.node.Node.(Node.java:158)
at org.elasticsearch.node.Node.(Node.java:140)
at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:143)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:270)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

Refer to the log for complete error details.


(David Pilato) #3

It sounds like you have a proxy issue or something like this.
Have a look at https://www.elastic.co/guide/en/elasticsearch/plugins/current/_other_command_line_parameters.html#_proxy_settings

Otherwise, you can download manually from https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/mapper-attachments/2.3.4/mapper-attachments-2.3.4.zip then install with:

bin/plugin install file:///path/to/mapper-attachments-2.3.4.zip

(system) #4