Mapper-size plugin query

I have started using the mapper-size plugin with one of our elasticsearch 2.2.0 clusters. In kibana I'm seeing that this field has a type of unknown and is unindexed. I've tried updating the mapping to:

"_size": {
"enabled": true,
"type": "integer",
"index": "not_analyzed"

...which throws an error:

"Mapping definition for [_size] has unsupported parameters: [index : not_analyzed]"

Removing the "index" parameter deals with that but still this field is not searchable. The plugin docs say this field is searchable so how can I fix this?


_size is an integer. You don't need to define an analyzer.

It's automatically indexed and available for search as written in this example:

You just have to set it with:

"_size": {
  "enabled": true

You probably have something else wrong and I think that you did not reindex your data, right?

When I originally created added this field I did it as you have shown. As I'm doing this in a test environment I'm doing this against a newly created index.

As I say, the field is visible in kibana but the type is unknown and it is not searchable. So, given that the field is being calculated and displayed, it's not clear what I'm doing wrong. I've tried recreating the index, setting the type as integer and recreating the index pattern but it still displays in kibana as type "unknown".

Interesting. I would definitely move this thread to #kibana list and see what people says there.