Mapping file _settings.json does not exist for elasticsearch version 7

I'm using elastic search 7.13.2 and fscrawler-2.5. When I try to create a new job in fscrawler using bin/fscrawler testjob2 it prompts me to create a new job and creates a new job with config file here /root/.fscrawler/testjob2/_settings.json. Now when I run this job I'm getting an error that says "Fatal error received while running the crawler: [Mapping file _settings.json does not exist for elasticsearch version 7 in [/root/.fscrawler/_default] "

I'm new to elastic search ecosystem so forgive me if I'm missing something trivial but isn't the crawler supposed to read the config file from testjob2 folder? And if not found, use the default one? In my case, even when I place a dummy config file to _default folder I'm getting the same error while running the task.

The problem was I was using incompatible version of elastic search and fscrawler. GitHub - dadoonet/fscrawler: Elasticsearch File System Crawler (FS Crawler)

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.