Maps is shown in field statistic but not in dashboard

Hi all,
I'm facing some problem to draw a dashboard with geopoints.

As you can see i have a value mapped as geopoint, minimap is shown in fields statistic tabs. But when i try to build a dashboard, kibana replies me saying that there are not geopoint fields.

Could you help me please?



Are you using the Same Data View in the Maps?

Did you try increasing the Time Picker on the Map? <!--- This :slight_smile:

Here are a few steps you can take to troubleshoot and resolve the problem:

  1. Verify Mapping: Make sure that the field you're trying to use as a geopoint is correctly mapped as a geopoint type in Elasticsearch. You can check the mapping of your index in Kibana's Management > Index Patterns section.
  2. Refresh Index Pattern: After ensuring that the field is mapped as a geopoint, go to Kibana's Management > Index Patterns, select your index pattern, and click the "Refresh field list" button. This ensures that Kibana is aware of the latest mapping changes.
  3. Coordinate Format: Double-check the coordinate format of your geopoint field. It should be in the format [longitude, latitude]. If your data is in a different format, you might need to create a scripted field to extract and format the coordinates correctly.
  4. Zoom Level in Map Visualization: When creating a map visualization in Kibana, make sure to adjust the zoom level appropriately. If the data points are scattered across a large area, zoom out to see all the points.
  5. Permissions: Ensure that the user account you are using has the necessary permissions to access the geopoint field and visualize it in a dashboard.
  6. Kibana Version: Check if you are using a compatible version of Kibana for geospatial features. Some features may vary between versions, so it's good to be on a version that supports the functionalities you need.
  7. GeoJSON Data: If you are dealing with GeoJSON data, make sure that the GeoJSON field is correctly identified and used in your visualizations.
  8. Index Pattern Settings: In your index pattern settings, confirm that the geopoint field is configured correctly, and the "Format" is set to "Geo_point."

If the issue persists, providing more specific details about your setup, sample documents, and the steps you've taken can help in giving more targeted assistance. Feel free to share more details or ask specific questions!

1 Like

Hello everyone,
today the problem is solved.
I recreated the dataview, maybe some previous settings had been saved.

Another question, how can I remove the shapes from the maps? I would like to keep only the circles in the map.

Thanks for the support.

1 Like

That dashed shape is there to indicate you are seeing partial results.

To remove it, you'd need to filter your data or change to render aggregated data (hexagons, clusters, or grids). More details on this guide

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.