Master node refuse to accept its role

Hi,

I am starting a new cluster and I want it to be set with two nodes. One is
a data only node and the other is a master only node. Both nodes are hosted
on Amazon EC2 and are in the same region

Here is my configuration for both nodes.

Master Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_m"
node.master: true
node.data: false
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
discovery.zen.ping.timeout: 600s

Data Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_d"
path.data: /elasticdata/data/
node.master: false
node.data: true
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
iscovery.zen.ping.timeout: 600s

Now when I start the elasticsearch service on the Master Node, the service
starts fine with now errors in the logs. Yet it keeps giving me a 503
whenever I try to connect to it.

Calling: *curl -XGET localhost:9200/_stats *on the master node gives the
following exception:

{

"error": "ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state
not recovered / initialized];[SERVICE_UNAVAILABLE/2/no
master];]","status":503

}

So it seems for some weird reason that it does not elect itself as a master
node.

When checking the logs on the data node, it seems that it is able to detect
the master node yet cannot connect to it with the following error in the
logs:

[2015-04-22 10:38:03,604][INFO ][discovery.ec2 ] [node_d]
failed to send join request to master
[[node_m][][][inet[]]{data=false, master=t$

I removed the IP addresses for security but I assure you they are correct.

So what is going on here, and why is my master node failing to see itself
as a master node?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Which versions for:

Elasticsearch
Cloud-aws-plugin

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 avr. 2015 à 12:41, Zaid Amir redserpent7@gmail.com a écrit :

Hi,

I am starting a new cluster and I want it to be set with two nodes. One is a data only node and the other is a master only node. Both nodes are hosted on Amazon EC2 and are in the same region

Here is my configuration for both nodes.

Master Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_m"
node.master: true
node.data: false
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
discovery.zen.ping.timeout: 600s

Data Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_d"
path.data: /elasticdata/data/
node.master: false
node.data: true
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
iscovery.zen.ping.timeout: 600s

Now when I start the elasticsearch service on the Master Node, the service starts fine with now errors in the logs. Yet it keeps giving me a 503 whenever I try to connect to it.

Calling: curl -XGET localhost:9200/_stats on the master node gives the following exception:

{
"error": "ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];[SERVICE_UNAVAILABLE/2/no master];]","status":503
}

So it seems for some weird reason that it does not elect itself as a master node.

When checking the logs on the data node, it seems that it is able to detect the master node yet cannot connect to it with the following error in the logs:

[2015-04-22 10:38:03,604][INFO ][discovery.ec2 ] [node_d] failed to send join request to master [[node_m][][][inet[]]{data=false, master=t$

I removed the IP addresses for security but I assure you they are correct.

So what is going on here, and why is my master node failing to see itself as a master node?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1328C370-7431-4006-B7F6-C717D9AF36C6%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Both nodes have:

ElasticSearch: 1.5.0
Cloud-AWS: 2.5.0

On Wednesday, April 22, 2015 at 2:29:39 PM UTC+3, David Pilato wrote:

Which versions for:

Elasticsearch
Cloud-aws-plugin

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 avr. 2015 à 12:41, Zaid Amir <redse...@gmail.com <javascript:>> a
écrit :

Hi,

I am starting a new cluster and I want it to be set with two nodes. One is
a data only node and the other is a master only node. Both nodes are hosted
on Amazon EC2 and are in the same region

Here is my configuration for both nodes.

Master Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_m"
node.master: true
node.data: false
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
discovery.zen.ping.timeout: 600s

Data Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_d"
path.data: /elasticdata/data/
node.master: false
node.data: true
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
iscovery.zen.ping.timeout: 600s

Now when I start the elasticsearch service on the Master Node, the service
starts fine with now errors in the logs. Yet it keeps giving me a 503
whenever I try to connect to it.

Calling: *curl -XGET localhost:9200/_stats *on the master node gives the
following exception:

{

"error": "ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state
not recovered / initialized];[SERVICE_UNAVAILABLE/2/no
master];]","status":503

}

So it seems for some weird reason that it does not elect itself as a
master node.

When checking the logs on the data node, it seems that it is able to
detect the master node yet cannot connect to it with the following error in
the logs:

[2015-04-22 10:38:03,604][INFO ][discovery.ec2 ] [node_d]
failed to send join request to master
[[node_m][][][inet[]]{data=false, master=t$

I removed the IP addresses for security but I assure you they are correct.

So what is going on here, and why is my master node failing to see itself
as a master node?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/30ee9166-5590-434b-8fc2-d8b1196e4650%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I just ran a small test on a ec2 instance.

I just set

node.master: true
node.data: false

on a node without and then with cloud-aws-plugin and it worked well in both cases.

Could you try to simplify your settings to see what setting is actually causing this?

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
discovery.type: ec2
node.master: true
node.data: false

--
David Pilato - Developer | Evangelist
elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 22 avr. 2015 à 13:33, Zaid Amir redserpent7@gmail.com a écrit :

Both nodes have:

ElasticSearch: 1.5.0
Cloud-AWS: 2.5.0

On Wednesday, April 22, 2015 at 2:29:39 PM UTC+3, David Pilato wrote:
Which versions for:

Elasticsearch
Cloud-aws-plugin

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 avr. 2015 à 12:41, Zaid Amir <redse...@gmail.com <javascript:>> a écrit :

Hi,

I am starting a new cluster and I want it to be set with two nodes. One is a data only node and the other is a master only node. Both nodes are hosted on Amazon EC2 and are in the same region

Here is my configuration for both nodes.

Master Node:

cluster.name http://cluster.name/: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name http://node.name/: "node_m"
node.master: true
node.data: false
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
discovery.zen.ping.timeout: 600s

Data Node:

cluster.name http://cluster.name/: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name http://node.name/: "node_d"
path.data: /elasticdata/data/
node.master: false
node.data: true
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
iscovery.zen.ping.timeout: 600s

Now when I start the elasticsearch service on the Master Node, the service starts fine with now errors in the logs. Yet it keeps giving me a 503 whenever I try to connect to it.

Calling: curl -XGET localhost:9200/_stats on the master node gives the following exception:

{
"error": "ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];[SERVICE_UNAVAILABLE/2/no master];]","status":503
}

So it seems for some weird reason that it does not elect itself as a master node.

When checking the logs on the data node, it seems that it is able to detect the master node yet cannot connect to it with the following error in the logs:

[2015-04-22 10:38:03,604][INFO ][discovery.ec2 ] [node_d] failed to send join request to master [[node_m][][][inet[]]{data=false, master=t$

I removed the IP addresses for security but I assure you they are correct.

So what is going on here, and why is my master node failing to see itself as a master node?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/30ee9166-5590-434b-8fc2-d8b1196e4650%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/30ee9166-5590-434b-8fc2-d8b1196e4650%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/862D11C0-116C-48ED-8948-AE99A25B0520%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

I tried your configuration and though the master node was able to start.
Now the nodes are unable to see each other. So the data node is now
reporting that it cannot see any master nodes and its failing to start.

On Wednesday, April 22, 2015 at 4:01:12 PM UTC+3, David Pilato wrote:

I just ran a small test on a ec2 instance.

I just set

node.master: true
node.data: false

on a node without and then with cloud-aws-plugin and it worked well in
both cases.

Could you try to simplify your settings to see what setting is actually
causing this?

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
discovery.type: ec2
node.master: true
node.data: false

--
David Pilato - Developer | Evangelist
elastic.co http://elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 22 avr. 2015 à 13:33, Zaid Amir <redse...@gmail.com <javascript:>> a
écrit :

Both nodes have:

ElasticSearch: 1.5.0
Cloud-AWS: 2.5.0

On Wednesday, April 22, 2015 at 2:29:39 PM UTC+3, David Pilato wrote:

Which versions for:

Elasticsearch
Cloud-aws-plugin

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 avr. 2015 à 12:41, Zaid Amir redse...@gmail.com a écrit :

Hi,

I am starting a new cluster and I want it to be set with two nodes. One
is a data only node and the other is a master only node. Both nodes are
hosted on Amazon EC2 and are in the same region

Here is my configuration for both nodes.

Master Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_m"
node.master: true
node.data: false
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
discovery.zen.ping.timeout: 600s

Data Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_d"
path.data: /elasticdata/data/
node.master: false
node.data: true
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
iscovery.zen.ping.timeout: 600s

Now when I start the elasticsearch service on the Master Node, the
service starts fine with now errors in the logs. Yet it keeps giving me a
503 whenever I try to connect to it.

Calling: *curl -XGET localhost:9200/_stats *on the master node gives the
following exception:

{

"error": "ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state
not recovered / initialized];[SERVICE_UNAVAILABLE/2/no
master];]","status":503

}

So it seems for some weird reason that it does not elect itself as a
master node.

When checking the logs on the data node, it seems that it is able to
detect the master node yet cannot connect to it with the following error in
the logs:

[2015-04-22 10:38:03,604][INFO ][discovery.ec2 ] [node_d]
failed to send join request to master
[[node_m][][][inet[]]{data=false, master=t$

I removed the IP addresses for security but I assure you they are correct.

So what is going on here, and why is my master node failing to see itself
as a master node?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/30ee9166-5590-434b-8fc2-d8b1196e4650%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/30ee9166-5590-434b-8fc2-d8b1196e4650%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/408f2654-5617-49fc-b04c-f4aa5c961990%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

So could you then add one by one the other settings you defined and report here which setting is causing your initial issue?

David

Le 23 avr. 2015 à 09:17, Zaid Amir redserpent7@gmail.com a écrit :

I tried your configuration and though the master node was able to start. Now the nodes are unable to see each other. So the data node is now reporting that it cannot see any master nodes and its failing to start.

On Wednesday, April 22, 2015 at 4:01:12 PM UTC+3, David Pilato wrote:
I just ran a small test on a ec2 instance.

I just set

node.master: true
node.data: false

on a node without and then with cloud-aws-plugin and it worked well in both cases.

Could you try to simplify your settings to see what setting is actually causing this?

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
discovery.type: ec2
node.master: true
node.data: false

--
David Pilato - Developer | Evangelist
elastic.co
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 22 avr. 2015 à 13:33, Zaid Amir redse...@gmail.com a écrit :

Both nodes have:

ElasticSearch: 1.5.0
Cloud-AWS: 2.5.0

On Wednesday, April 22, 2015 at 2:29:39 PM UTC+3, David Pilato wrote:
Which versions for:

Elasticsearch
Cloud-aws-plugin

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 22 avr. 2015 à 12:41, Zaid Amir redse...@gmail.com a écrit :

Hi,

I am starting a new cluster and I want it to be set with two nodes. One is a data only node and the other is a master only node. Both nodes are hosted on Amazon EC2 and are in the same region

Here is my configuration for both nodes.

Master Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_m"
node.master: true
node.data: false
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
discovery.zen.ping.timeout: 600s

Data Node:

cluster.name: testingelastic
cloud.aws.access_key: <ACCESS_KEY>
cloud.aws.secret_key: <SECRET_KEY>
cloud.aws.protocol: http
discovery.type: ec2
discovery.ec2.tag.Search: Elastic
discovery.ec2.ping_timeout: 90s
discovery.zen.ping.multicast.enabled: false
node.name: "node_d"
path.data: /elasticdata/data/
node.master: false
node.data: true
index.number_of_shards: 1
index.number_of_replicas: 1
network.publish_host: <STATIC_IP_ADDRESS>
http.enabled: true
http.cors.enables: true
http.cors.allow-origin: "*"
iscovery.zen.ping.timeout: 600s

Now when I start the elasticsearch service on the Master Node, the service starts fine with now errors in the logs. Yet it keeps giving me a 503 whenever I try to connect to it.

Calling: curl -XGET localhost:9200/_stats on the master node gives the following exception:

{
"error": "ClusterBlockException[blocked by: [SERVICE_UNAVAILABLE/1/state not recovered / initialized];[SERVICE_UNAVAILABLE/2/no master];]","status":503
}

So it seems for some weird reason that it does not elect itself as a master node.

When checking the logs on the data node, it seems that it is able to detect the master node yet cannot connect to it with the following error in the logs:

[2015-04-22 10:38:03,604][INFO ][discovery.ec2 ] [node_d] failed to send join request to master [[node_m][][][inet[]]{data=false, master=t$

I removed the IP addresses for security but I assure you they are correct.

So what is going on here, and why is my master node failing to see itself as a master node?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c5466db8-f614-4d52-a245-bd361b6953ad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/30ee9166-5590-434b-8fc2-d8b1196e4650%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/408f2654-5617-49fc-b04c-f4aa5c961990%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/57809FAD-4A2A-45AF-8349-C093A8D6FF99%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.