Master not discovered yet, this node has not previously joined a bootstrapped


My environment: =============================================================
DNS Configuration: vm1 qa-node-1 vm2 qa-node-2

Ports 9200 , 9300 open on all VMs

elasticsearch.yml on VM1: Hostname: logging-qa qa-node-1
node.master: true true
node.ingest: true /app/files/data/elasticsearch
path.logs: /app/files/log/elasticsearch
bootstrap.memory_lock: true
http.port: 9200
discovery.seed_hosts: ["", ""]
cluster.initial_master_nodes: ["qa-node-1", "qa-node-2"]

However, when I want to start (initial) cluster, I get the bellow error:

[2019-06-27T05:08:58,411][WARN ][o.e.c.c.ClusterFormationFailureHelper] [qa-node-1] master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [qa-node-1, qa-node-2] to bootstrap a cluster: have discovered []; discovery will continue using [] from hosts providers and [{qa-node-1}{EwWR4oWtQrWAhr_aZC7AIQ}{6w0qvpPCT8CCSf2UqV36VA}{}{}{ml.machine_memory=1902309376, xpack.installed=true, ml.max_open_jobs=20}] from last-known cluster state; node term 0, last-accepted version 0 in term 0

Any idea please?
I do not know why ''''''have discovered [] ''''''' is empty.

Please let me know if I need to modify my yaml file.

This message is telling us that this node (qa-node-1) has not been able to discover the other node (qa-node-2) despite trying to connect to it at Normally this is either because the other node is not running, or else there's a connectivity issue.

Thanks David,

This is a new cluster I am running, I started the first node, qa-node-1, I have both nodes in config file. Why it doesn’t able to make itself as a master?

If that is the case, even if I start the other node at the same time, I will get the same error on the other node too.

My question is how should I run the cluster? Should I run both nodes at the same time???

If that is the connection issue, the other node, qa-node-2 is on another VM (vm2). And VM2 is up and running and the port is also open

Any idea please??

Yes, this is a 2-node cluster so you need both nodes to be running for it to work. The first node has no way of knowing it's the first node, so can't safely become the master on its own. It needs to contact the other node first.

Also, is my config file configured correctly?
What I also noticed, in the error message, nothing is available between in have discovered part, is this ok?
Any idea please?
have discovered []

The config file looks fine, but the have discovered [] indicates that the nodes can't find each other. If they're both running then I would guess there's a problem with the network.

Thanks David again.

I have opened ports 9200 and 9300 on both vms and also for now, disabled selinux just in case, I am able to telnet to each other and also pinging works fine with IP and name too.

Today I will run both nodes and will see what will happen, if I couldn’t resolve any possible issues I will reach out again for your help please


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.