Metricbeat authentication problem with kibana


(Ijaz Ahmad Khan) #1

hi

i have installed 6.1.1 versions of both elastic and kibana and configured the client with metricbeat , i can see the data is comming and index is create , i can curl it with username nad password , everything is fine , but when i try to open kibana , and after i logged in , then i click on the discover tab , there pop up an authentication error ,

rror: [object Object]: [security_exception] missing authentication token for REST request [/metricbeat-/_field_caps?fields=&ignore_unavailable=true&allow_no_indices=false], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }
request/<@http://10.3.10.44:5601/bundles/kibana.bundle.js?v=16350:61:632371
processQueue@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:132456
scheduleProcessQueue/<@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:133349
$digest@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:144239
$apply@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:147007
done@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:100015
completeRequest@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:104697
createHttpBackend/</xhr.onload@http://10.3.10.44:5601/bundles/commons.bundle.js?v=16350:29:105435

why there is no error while using curl?


(Ijaz Ahmad Khan) #4

turns out that its not specfic to metricbeat , the error now shows on other indices as well.

[object Object]: [security_exception] missing authentication token for REST request [/.monitoring-alerts-6/_field_caps?fields=*&ignore_unavailable=true&allow_no_indices=false], with { header={ WWW-Authenticate="Basic …


(Carlos Pérez Aradros) #5

Hi @ijazadm, this is probably an error in kibana configuration, have a look to https://www.elastic.co/guide/en/kibana/current/security-settings-kb.html.

I'm moving this topic to Kibana


(Ijaz Ahmad Khan) #6

Hi ,

Thanks.

Fixed.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.