Missing authentication token when combining metricbeat and logstash


(Guta Saputra) #1

helo, i have an issue with metricbeat.
before i install xpack, metricbeat running very well.

but suddenly after i install xpack, i cant access it from my kibana.
i run this command in my terminal :

curl -XGET 'http://localhost:9200/metricbeat-*/_search?pretty'

but i got this error msg

missing authentication token for REST request [/metricbeat-*/_search?pretty]

i already changed my metricbeat.yml

Optional protocol and basic auth credentials.

#protocol: "https"
username: "elastic"
password: "techno2013"

#output.logstash:

The Logstash hosts

hosts: ["localhost:5044"]

but i still got the same error msg.
pls guys help me out.

thank you.

PS :
actually i already post this on

but the forum that i assigned is metricbeat, not logstash.
based on responses from the other users, they suggest me to repost this to logstash forum.

thanks


(Magnus Bäck) #2

It sounds like you enabled authentication for Elasticsearch. Then you have to provide authentication credentials in your curl commands. I don't see how that's related to either Logstash or Metricbeat.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.