Metricbeat Kibana dashboard


#1

After I updated to 5 alpha 5 for ES, Kibana, and Metricbeat I've noticed the metrics being collected from servers output has changed and look very wrong in comparison to what they were prior to the update.

I even went as far as removing metricbeat and the dashboard and re-adding them all as well as index templates in es.

Has anyone experienced issues with the output of metricbeats in alpha 5?

https://d17oy1vhnax1f7.cloudfront.net/items/1o1H3e2i0C312O3g2N35/Image%202016-08-23%20at%2012.34.37%20PM.png


(Tudor Golubenco) #2

Thanks for running Metricbeat. In which way exactly do the values seem wrong? Where you seeing different values with alpha4?


#3

Well, in alpha 4 they were displaying in more human readable format. so the percentages were 1-100% and the consumption sizes were in MB/GB. I'm not sure if there was a change in the config or not. This seems to be related to the beat itself... This is what it looks like as the output from the beats.


#4

My issue seems to be the same issue as this post System memory usuage in MBytes

I'm going to look into the field management and see if it resolves what I'm seeing.

@monica, in that post, you mentioned a change in the next release. Was there a change from alpha4 to alpha5 in how Metricbeat displays information?


#5

The field format in the index patterns fixed my issue. It's very strange because I really feel like this was set this way when I initially setup Metricbeat. Either way, I got what I needed.

Just because it might be easier for people looking for this answer I posted a screenshot of where the setting is.

Is there a way to make this change in bulk?


#6

Just to put another update to this. I was looking at the advanced settings in Kibana and saw this...

To me, that looks like it should format the index fields properly, but it doesn't seem to be getting applied. The field format option fixes it, but I feel this shouldn't have to be set. Am I wrong with how I am seeing this?

Perhaps this is actually a Kibana problem not a Metricbeat problem.


(ruflin) #7

@Cral The next release of Metricbeat we plan to ship with a import_dashbaord binary which makes it very easy to import the index pattern and the dashboards. As soon as you import our generated index pattern, all the fields will be set with the right formatter.


(Monica Sarbu) #8

@Crai The right format should have been set already in the index pattern of the new version of Metricbeat. Did you load the dashboards and the index pattern by running the kibana/import_dashboards script from the Metricbeat package. In alpha4 and alpha5 there are two scripts available, one for linux (import_dashboards.sh), and one for windows (import_dashboards.ps1). Here is the link to the documentation.

With the next release, the index pattern is generated automatically from etc/fields.yml, so each field that is exported has the right format associated, and you will be able to see in Kibana the bytes and the percentages fields in a nice way. For this you just need to run import_dashboards. If you want to try the latest Metricbeat version, here is the link.


#9

Thanks for getting back to me. After I updated to alpha 5 I ran the import dashboard script, and I even deleted the indices and index templates to start fresh with data. The only way I was able to get it fixed was to manually format the fields.

Is there a way to remove them then reimport them? would I just delete the dashboards from Kibana then run the script again?


(system) #10

This topic was automatically closed after 21 days. New replies are no longer allowed.