Metricbeat: Kibana Dashboard with (almost) no data


I have a group of Metricbeats collecting metrics every 1m. When I try to view those metrics in the Dashboard / [Metricbeat System] Host overview ECS I get something like this:

Not much being showed and some visualizations are just incorrect.

When I change the time interval from 15m to 24h I get this:

Way better!

I didn't have this problem whem my Beats were set to collect every 10s.

I think this could be related to this other post here: Metricbeat showing Zero_Percent CPU utilization

So what am I doing wrong? Shouldn't I be able to see, say, last 5m metrics, for instance? Is this related to the dashboard's visualizations parameters (maybe they only work for < 1m collects)?

Thank you

I think this has something to do with Timezones...

I know that I am receiving data, but I can only make them show in the dashboards when I change the time interval 2 hours to the past.

Kibana has a general setting for which the default is to consider the Browser's timezone. Tried to change it to Brazil/East But still no luck.

One more finding: it seens that the problem only occurs with MEtricbeat's System dashboards. Other dashboards as well as Discover show data being indexing at the correct time.

Hi @ffknob, sorry for the late response. What Metricbeat/Elasticsearch/Kibana version are you using? I will try to reproduce this problem on my side! Thank you!

Hi @Kaiyan_Sheng, now I have 7.6.2 both on the cluster and in the agents.

Once again, I'm only noticing this strange behavior with Metricbeat's "System" dashboards. When I set the time interval for, say, the last 5 minutes, I get data in all of them except for those ones.

Thanks you!

I was able to reproduce this problem! Could you open a github issue for this please? If not, I can create one! Thanks!!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.