Metricbeat System dashboard not show metric below the time range of 30 minutes

Hello Everyone,

Since two days i'm facing an issue with kibana dashboard, i unable to see proper metric with in the time range of 30 min.

This issue was not there before, i went through google and spent lot of time over there but no proper solution.

I updated ELK 7.5.2 to latest release 7.6.2 but issue remains same

I found below link, but myself i felt this is not the proper solution because whenever i run metribeat setup -e changes are reverting to normal and issue comes back again, and also changing settings at @Paneloptions --> @interval from auto to 1m is only working after two or three refresh.

https://discuss.elastic.co/t/kibana-metricbeat-system-dashboard-not-working-correctly-with-time-range-15-minutes-or-less/127140

could you please anyone help me out from this issue, it is really irritating me, Plz find the screen shot

About having to refresh:

If your beat is sending data at a lower interval, 1m might still be too low for data to consistently show up. Did you change the period settings to something else than the default in your metricbeat config? It might be worth trying higher values than 1m, then there should always be data in the last bucket.

About the setup routine resetting your visualizations:
When running setup you don't have to include the dashboard creation - specify --index-management and --pipelines explicitly, but not --dashboards:

https://www.elastic.co/guide/en/beats/devguide/current/import-dashboards.html#import-dashboards

Usage:
metricbeat setup [flags]

Flags:
--dashboards Setup dashboards
-h, --help help for setup
--index-management Setup all components related to Elasticsearch index management, including template, ilm policy and rollover alias
--pipelines Setup Ingest pipelines

The flags are useful when you don’t want to load everything.

Another approach:
If you are customizing your visualizations, beats has an option to import them from a local file instead of re-building them: https://www.elastic.co/guide/en/beats/devguide/current/import-dashboards.html#import-dashboard-options. You could provide your modified dashboard like this.

Thank You @flash1293 after changing to higher value, i don't see any issue but instead of changing this value for each every panel is there any way to get applied these changes to all the panels and all the dash boards.

Unfortunately there is no way to do it automatically - you could use the saved objects api to export all visualizations using a script, applying the change there and re-importing them via API again. But to my knowledge there is no pre-built solution for this.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.