Kibana: Metricbeat System dashboard not working correctly with time range 15 minutes or less

Whenever I select a time range lower than 30 minutes the dashboard for Metricbeat System doesn't seem to work properly. The gauges don't fill up at all and the network stats don't measure anything at all as well as the disk usage percentage, but the graphs seem to work fine as well as the number of processes.

Metricbeat System Overview - Time Range 10 minutes - Refresh 5 Seconds

Metricbeat Host Overview - Time Range 1 minute - Refresh 5 Seconds

Metricbeat System Overview - Time Range 30 minutes - Refresh 5 Seconds

Metricbeat Host Overview - Time Range 30 minutes - Refresh 5 Seconds

I have checked with many time ranges and it seems that the time limit is around 13 minutes, but even then the data shows up every other auto-refresh interval of 5 seconds. I also checked in the discover section and all the Metricbeat info is seems to be captured and processed correctly.

I am running ELK 6.2.2 as docker services inside a single-node swarm and the info is beign sent from other swarm services, each running a copy of Metricbeat and Filebeat 6.2.2. All of this is running inside a virtual machine running Red Hat Enterprise Linux 7.

The gauge and metric visualizations in Time Series Visual Builder only show the "last bucket" of the aggregation that powers them, it doesn't automatically sum up the values for the entire time range selected in the time picker. I'm guessing if you look in the Panel Options of these visualizations the "interval" will be set to "auto". That means if you've selected a 15 minute time range, it's probably picking a 1 minute interval or something like that, which means the value you're seeing in the visualization is only the value from the last minute. This would explain why they seem to work inconsistently, sometimes you've got data for the last minute, sometimes not. You might have to play around with the "interval" and "drop last bucket" options to find something that works well for your use case.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.