Metricbeat output to logstash then no data in dashboards

Hello,

I pointed the output to logstash from Metricbeat & i am able to see the data in discovery. But no data in Metricbeat dashboards.
IN Metricbeat: ym file
output.logstash:
hosts: ['X.x.X.x:5044']
loadbalance: true
index: heartbeat
Logstash Output to Elasticsearch:
output {
elasticsearch {
hosts => ["x.x.x.x"]
manage_template => false
index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"

Can any one please help ?
Thank you
PRaveen

Are you using, the version 7.x? The ILM is enabled by default.
If yes try the same solution as here.

Hello Mathew,

Yes i am using 7.1v.
Below configuration in metricbeat.yml suggesting index name metricbeat.
output.logstash:
hosts: ['X.x.X.x:5044']
loadbalance: true
index: metricbeat

Logstash Output to Elasticsearch:
output {
elasticsearch {
hosts => ["x.x.x.x"]
manage_template => false
index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"

now i am seeing, beatwise indices in Kibana management.
I tried by disabling the Index Lifecycl management & enable the ILM but no use.

I AM SEEEING EVERY BEAT HAS THEIR OWN INDICSES IN KIBANA MANAGEMENT.

still i am not seeing any data in dashboards

@PraveenKT
Do you have Data in your indices?
Is there any error on the dashboards?
How do you ingest your data? (beats to elasticsearch or logstash inbetween)

Thank you for answering.

Hello Mathew,

I already posted the configuration in question. sending data from beats to logstash.
Issue got resolved. Reason for not showing the data in Panels(dashboard) is fields used in the panels(dashboards) are changed. I changed to correct field, for example move the field "host.name" to "host.name.keyword". Like this i changed the fields in non working panels (dashboards)