Metricbeats dashboards for Kubernetes controller manager

For some reason the visualizations of "[Metricbeat Kubernetes] Controller Manager" are corrupted.

I'm not getting any data on the dashboard, so I drilled down to the panels and saw that the fields on the visualizations are empty (see screenshot). Also some settings like index pattern was empty (see screenshot). I've tried deleting the visualizations and dashboards then reloading them again, but still the same thing.

Field is empty

Index pattern is empty

Has anyone been able to use the "[Metricbeat Kubernetes] Controller Manager" dashboard? Where could the corruption be coming from?

I'm on v7.6.

Hmmm I tried 7.6.2 and the field is not empty. Could you try to delete the dashboard and rerun ./metricbeat setup again?

Sorry for my late response. I tried to delete the dashboards and visualizations but still the same issue.

Is the data for setting up dashboards/visualizations coming from metricbeat? Could it be my installation of metricbeat thats missing some data?

Metricbeat was installed using rpm if that makes any difference.

Hi @camilisette I think this is actually a bug in the dashboard itself! I'm working on a PR to fix this and will post the link here once I have it ready! Sorry for the late response!!

No worries. Thanks! I'll wait for your next update.

1 Like

https://github.com/elastic/beats/pull/18865 Here is the PR to fix the dashboards. I found out this problem not only exist in kubernetes controller manager dashboard :frowning_face: The part that will fix kubernetes controller manager dashboard is simply this: https://github.com/elastic/beats/pull/18865/files#diff-6ca429ed0ebddf07cb4303674d564e65R332