Minimum_master_node not working as expected

Elastic Search Version: 0.90.1
Number of servers: 16
Nodes: 32 (2 nodes per server, each node is named node1-a, node1-b,
node2-a, node2-b, etc...)

When I use N/2+1 to set the "discovery.zen.minimum_master_nodes":

discovery.zen.minimum_master_nodes: 17

The node will never join the cluster. I can set it to:

discovery.zen.minimum_master_nodes: 5

And it joins, but setting it to any number above 5 and it all not join.

Currently I have 4 hosts in the "discovery.zen.ping.unicast.hosts: "

discovery.zen.ping.unicast.hosts: ["node1", "node6", "node11", "node16"]

If I change "discovery.zen.minimum_master_nodes: 5" to "6" the node will
not join the cluster. However if I add an additional host to
"discovery.zen.ping.unicast.hosts:" the node will then join the cluster.
This behavior is consistant, +1 to master_node and I need to add a host to
unicast setting.

What is the relationship between "discovery.zen.minimum_master_nodes:" and
"discovery.zen.ping.unicast.hosts:"? Also, I know this is related to
running two nodes on the same host, but would like to get this working.
(Trace Attached)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hopefully someone will answer you in the elasticsearch group. I've
actually left this value as 4 in our clusters, so I've never tried the
n/2+1 solution. My assumption (no reason or proof :slight_smile: is that this number
has to be less then or equal to the unicast.hosts list. If you added a 5th
value would minimum_master_nodes of 6 work, and if you added 6th value
would 7 work, etc etc.

I do set the gateway.recover_after_nodes and gateway.expected_nodes to the
number of nodes though.

Andy

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

+1 I've learned with experience (and pain) that the number of unicast.hosts
list must be greater or equals to the n/2+1 set for minimum_master_nodes. I
don't really know the underlying reason for that though.

On Tuesday, June 25, 2013 9:24:23 AM UTC-4, Andy Wick wrote:

Hopefully someone will answer you in the elasticsearch group. I've
actually left this value as 4 in our clusters, so I've never tried the
n/2+1 solution. My assumption (no reason or proof :slight_smile: is that this number
has to be less then or equal to the unicast.hosts list. If you added a 5th
value would minimum_master_nodes of 6 work, and if you added 6th value
would 7 work, etc etc.

I do set the gateway.recover_after_nodes and gateway.expected_nodes to the
number of nodes though.

Andy

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

If this is true, it is a bug. This should not be the intended behaviour.

Please can you open an issue describing the exact steps to reproduce this,
and we'll take a look at it

thanks

Clint

On 25 June 2013 21:13, Jérôme Gagnon jerome.gagnon.1@gmail.com wrote:

+1 I've learned with experience (and pain) that the number of
unicast.hosts list must be greater or equals to the n/2+1 set
for minimum_master_nodes. I don't really know the underlying reason for
that though.

On Tuesday, June 25, 2013 9:24:23 AM UTC-4, Andy Wick wrote:

Hopefully someone will answer you in the elasticsearch group. I've
actually left this value as 4 in our clusters, so I've never tried the
n/2+1 solution. My assumption (no reason or proof :slight_smile: is that this number
has to be less then or equal to the unicast.hosts list. If you added a 5th
value would minimum_master_nodes of 6 work, and if you added 6th value
would 7 work, etc etc.

I do set the gateway.recover_after_**nodes and gateway.expected_nodes to
the number of nodes though.

Andy

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Clinton Gormley wrote:

If this is true, it is a bug. This should not be the intended
behaviour.

Please can you open an issue describing the exact steps to
reproduce this,
and we'll take a look at it

Apologies, Scott, for not noting here that I opened an issue for
this. Alex closed yours as a duplicate.

https://github.com/elasticsearch/elasticsearch/issues/3262

We're still looking into what exactly happens in this scenario.

Drew

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.