Minimum_master_nodes setting not taking effect


(Sebastianhoitz) #1

I have changed my elasticsearch minimum_mast_node configuration on every node to 2. However, after bringing every node back up, there is only 1 master node as shown by the head plugin.

Do I have to take any other actions for this setting change to take effect?


(Magnus B├Ąck) #2

There is always exactly one master node in the cluster. The minimum_master_node setting controls how many master-capable nodes must be present in the cluster for it to be operable.


(system) #3