Missing Indexes After upgrade


(Ryan S) #1

We upgraded our ES version to RC1.0 from 0.90.3. After restarting ES only
half of our indexes were showing up. The indexes were still on the
filesystem but were not being recognized by ES. Any ideas to what went
wrong?

There was one reoccurring error in the log:
Message not fully read (request) for [] and action [], resetting.

But it doesn't seem like this has anything to do with our data not being
available. All nodes report a version of 1.0.0.RC1, and there are no other
clusters or ES nodes on the network.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0f16f3b5-38e3-4f7f-98d6-2fa1ada4e4ca%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #2

Ryan,

Please check and and verify that every single node in your cluster has:

  1. Same ES version

  2. Same exact Java version (i.e. whatever is displayed when running java
    -version)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6b03662c-f982-4b40-8657-274137d31874%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ryan S) #3

These have both been confirmed. We are running Java 1.7.0_15.

On Wed, Jan 29, 2014 at 12:24 PM, Binh Ly binh@hibalo.com wrote:

Ryan,

Please check and and verify that every single node in your cluster has:

  1. Same ES version

  2. Same exact Java version (i.e. whatever is displayed when running java
    -version)

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jsJrTjIrUWE/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6b03662c-f982-4b40-8657-274137d31874%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAa8yWWN9aUkcDQDd9uaD5XaYo7%2BYxHbjG-ubeeeA%3DOMgB7DRg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #4

Hey,

can you start with more logging and check the elasticsearch logfile, if any
more suspicious messages occur (maybe including a stacktrace), which might
help here?
Also, just to verify, eveything runs with correct version, please paste:

curl 'localhost:9200/_nodes/jvm?pretty' | grep version

--Alex

On Wed, Jan 29, 2014 at 10:25 PM, Ryan Shevchik ryan.shevchik@gmail.comwrote:

These have both been confirmed. We are running Java 1.7.0_15.

On Wed, Jan 29, 2014 at 12:24 PM, Binh Ly binh@hibalo.com wrote:

Ryan,

Please check and and verify that every single node in your cluster has:

  1. Same ES version

  2. Same exact Java version (i.e. whatever is displayed when running java
    -version)

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/jsJrTjIrUWE/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6b03662c-f982-4b40-8657-274137d31874%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAAa8yWWN9aUkcDQDd9uaD5XaYo7%2BYxHbjG-ubeeeA%3DOMgB7DRg%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM9PsA1CuF%3DqAvqcXfnkVZyjF97Pwib8S_0ZyKXYgTbiGw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5