Missing operating systems statistics on 2 nodes out of 5


(Alexander Vassilevski) #1

Hey guys,

I'm sorry if this is a duplicate post - I did in fact do various searches
in the group prior to writing this, but I'd be more than glad to use a URL
if someone has already solved this exact problem.

Here's a short description of the problem:

I have a cluster with 5 data nodes ( all eligible masters, with minimum 3
). I also have a no data no master node which I use for load balancing
search and indexing requests ( its the REST endpoint ).

The problem is that for data nodes 4 and 5 I am getting no OS statistics (
the ones provided by the sigar lib ).

The only difference between nodes 1-3 and 4,5 are that the last two were
installed via puppet.
There are no significant ( meaning nothing more nothing less, just
different values for IP's and hostnames) elasticsearch.yml config
differences and I haven't set anything unique on the last two nodes via
cluster permanent/transient, node or index settings.
I have tried restarting both all the individual nodes one by one and the
cluster as a whole and neither of these resolved the issue.

I am willing to provide config files, program output, anything, etc, so
that we can get this issue resolved - just let me know!

The elasticsearch version I'm using on all the nodes is 1.5.0, java is

-Alex V

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8a58934a-efba-4264-a5b8-b01a187efb80%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Are you using containers, Docker, LXC etc?

On 12 May 2015 at 18:22, Alexander Vassilevski <
alexander.vassilevski@gmail.com> wrote:

Hey guys,

I'm sorry if this is a duplicate post - I did in fact do various searches
in the group prior to writing this, but I'd be more than glad to use a URL
if someone has already solved this exact problem.

Here's a short description of the problem:

I have a cluster with 5 data nodes ( all eligible masters, with minimum 3
). I also have a no data no master node which I use for load balancing
search and indexing requests ( its the REST endpoint ).

The problem is that for data nodes 4 and 5 I am getting no OS statistics (
the ones provided by the sigar lib ).

The only difference between nodes 1-3 and 4,5 are that the last two were
installed via puppet.
There are no significant ( meaning nothing more nothing less, just
different values for IP's and hostnames) elasticsearch.yml config
differences and I haven't set anything unique on the last two nodes via
cluster permanent/transient, node or index settings.
I have tried restarting both all the individual nodes one by one and the
cluster as a whole and neither of these resolved the issue.

I am willing to provide config files, program output, anything, etc, so
that we can get this issue resolved - just let me know!

The elasticsearch version I'm using on all the nodes is 1.5.0, java is

-Alex V

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8a58934a-efba-4264-a5b8-b01a187efb80%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a58934a-efba-4264-a5b8-b01a187efb80%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-mBGho%2BsCQ7jkmN-PrgwxqWQvhhjfcxjkbTM8tOzHhjA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3