Missing secure_url setting for Jira integration

Hi guys,
I was trying to integrate Jira account to raise issues from Kibana, but I'm getting this error.

  "error" : {
    "root_cause" : [
        "type" : "settings_exception",
        "reason" : "invalid jira [monitoring] account settings. missing required [secure_url] setting"
    "type" : "settings_exception",
    "reason" : "invalid jira [monitoring] account settings. missing required [secure_url] setting"
  "status" : 500

I've already added secure_url in elasticsearch-keystore as mentioned in this doc https://www.elastic.co/guide/en/elasticsearch/reference/current/actions-jira.html. It looks something like this:

xpack.notification.jira.account.monitoring.secure_url= url
xpack.notification.jira.account.monitoring.secure_user= user
xpack.notification.jira.account.monitoring.secure_password= pass

I've also reloaded elasticsearch-keystore as mentioned in https://www.elastic.co/guide/en/elasticsearch/reference/7.7/secure-settings.html using

POST _nodes/reload_secure_settings
  "secure_settings_password": "s3cr3t" 

I also added following code to elasticsearch.yml and restarted the instance.

      # secure_url: triedPuttingUrlHere
          key: proj
          name: Bug
        summary: "X-Pack Issue"
        labels: ["auto"]

When I tried putting secure_url setting in elasticsearch.yml which is commented in above code. It asked me to add this setting in the elasticsearch-keystore since it is a secure setting, which I've already tried earlier.

Please help me in debugging the error asap. Thanks in advance!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.