MongoDB River Reindex


(tsturzl) #1

This morning we had an issue with Elastic Search on one of our production
servers. We had to reindex the entire thing. It appeared in several posts
http://elasticsearch-users.115913.n3.nabble.com/How-to-reindex-an-ES-index-td3089964.html
I've seen from various sources that the only real way to do this was remove
the index and recreate the river.

So I did exactly that. I removed the index, then I tried recreating the
river. I'm not getting this error:

{"error":"UnavailableShardsException[[_river][0] [2] shardIt, [0] active :

Timeout waiting for [1m], request: index {[_river][adn_demo][_meta],
source[\n{\n "type": "mongodb",\n "mongodb": {\n "servers":
[\n { "host": "10.128.3.250", "port": 27017 },\n {
"host": "10.128.4.5", "port": 27017 },\n { "host":
"10.128.4.6", "port": 27017 }\n ],\n "options": {
"secondary_read_preference": true },\n "db": "adn_demo",\n
"collection": "jobPosts"\n },\n "index": {\n "name":
"job_posts_index_prd",\n "type": "job_post_prd"\n
}\n}]}]","status":503}

I'm under the impression that I'm not part of a replica set as
"localhost:9200/_nodes/process?pretty" outputs:

{
"ok" : true,
"cluster_name" : "adnElasticsearch",
"nodes" : {
"oDBNxMd9QZ-vxnE7PoWFig" : {
"name" : "Professor X",
"transport_address" : "inet[web-api1]",
"hostname" : "web-api1",
"version" : "0.90.3",
"http_address" : "inet[web-api1",
"process" : {
"refresh_interval" : 1000,
"id" : 23372,
"max_file_descriptors" : 65535
}
}
}
}

However we duplicate ES to provide redundancy, so the 2 other servers are
configured like this:

{
"ok" : true,
"cluster_name" : "adnElasticsearch",
"nodes" : {
"aQS4U9axRryqnVN7RqFnWw" : {
"name" : "Anomaloco",
"transport_address" : "inet[/10.128.4.10:9300]",
"hostname" : "web-api3",
"version" : "0.90.3",
"http_address" : "inet[web-api3/10.128.4.10:9200]",
"process" : {
"refresh_interval" : 1000,
"id" : 25224,
"max_file_descriptors" : 65535
}
},
"NsKtV7UiSx2YPSJHGBs8RQ" : {
"name" : "Bullseye",
"transport_address" : "inet[web-api2/10.128.4.9:9300]",
"hostname" : "web-api2",
"version" : "0.90.3",
"http_address" : "inet[web-api2/10.128.4.9:9200]",
"process" : {
"refresh_interval" : 1000,
"id" : 804,
"max_file_descriptors" : 65535
}
}
}
}

I assume web-api1 got removed from the replica set when I removed the index.

I had been kind of dropped into this system when we lost our system
administrator. I'm not fluent in ElasticSearch, and I'm having troubles
finding out how to resolve this issue.

How do I recreate the index/river?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/129e8a55-5e31-4f2f-adec-f6b306128a5c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2