.monitoring-es-6-*インデックスファイルの保存期間変更

Elasticsearchのディスク容量が閾値を超えたので、indexがロックされました。
原因を調査しました。

原因
monitoring-es-6-*インデックスファイルが、7個あり、ギガ単位サイズでした。

対処
monitoring-es-6-*インデックスファイルを7日間保存から1日保存にしました。
しかし、対処の設定が反映されず、.monitoring-es-6-*のインデックスのファイル数が
一日ごとに、増えていきます。

設定方法が間違っているのでしょうか?

■設定コマンド
PUT _cluster/settings
{"persistent": {"xpack.monitoring.history.duration":"1d"}}

■保存期間の設定前の確認
{
"defaults" : {
"xpack" : {
"monitoring" : {
"history" : {
"duration" : "168h"
}
}
}
}
}

■保存期間の設定後の確認
{
"persistent" : {
"xpack" : {
"monitoring" : {
"history" : {
"duration" : "1d"
}
}
}
}
}

https://www.elastic.co/guide/en/elasticsearch/reference/current/monitoring-settings.html#general-monitoring-settings

This setting currently only impacts local -type exporters. Indices created using the http exporter will not be deleted automatically.

こちらによりますと、この設定がlocal typeのexporterを使っているときは有効だけれども、
http exporterを使っているときは、自動では消えませんと書いてあります。

http exporterを使っているということはありませんでしょうか?

tsgkdtさん
レス、ありがとうございます。

elasticsearch.yamlの設定を確認しました。
しかし、http exporter、local exporterの設定はありませんでした。
デフォルトの設定が、local exporterなので、http exporterは使ってなそうです。

そのため、.monitoring-es-6-*のインデックスが自動削除されない原因が
まだ不明です。

自動削除されない原因がわかりました。

確認したら、ベーシックライセンスでした。
そのため、インデックスは保存期間設定は不可でした。
https://www.elastic.co/jp/subscriptions

ありがとうございました。

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.