Monitoring history duration not getting updated elastic search 6.8.1

Hi, I have been trying to update the monitoring indices duration from default of 7 days to 1 day.

I have tried updating the cluster settings and have also tried updating the elasticsearch.yml.

However the change is not taking effect, and the monitoring indices older than 1 day are not getting deleted. can someone please help me understand why are older indices not getting deleted

Following is the addition that I did to elasticsearch.yml
xpack.monitoring.history.duration: 1d

Also tried updating the cluster settings by hitting the following endpoint

PUT _cluster/settings
  "persistent": {

After updating these settings I restarted the elastic search cluster using
sudo service elasticsearch restart

However even after doing these changes the settings are not getting updated. version of elasticsearch that i have been using is 6.8.1

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.