Moving data directory

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data directory to a new directory ? Can I simple 'cp /old/data /new/data' without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each
directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and
make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch
is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I mean that your modifications in elasticsearch.yml are probably not read as a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each directory over ending up with

/bigdata/elasticsearch/data/graylog2 and /bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:
On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data directory to a new directory ? Can I simple 'cp /old/data /new/data' without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

For the record I am on

Ubunutu 12.10 running the deb found at :
http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to the
new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of the
elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would still
start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the
cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I
mean that your modifications in elasticsearch.yml are probably not read as
a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each
directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and
make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch
is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can you paste here your path*** lines ?

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at : http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:
graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I mean that your modifications in elasticsearch.yml are probably not read as a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each directory over ending up with

/bigdata/elasticsearch/data/graylog2 and /bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:
On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data directory to a new directory ? Can I simple 'cp /old/data /new/data' without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

#################################### Paths
####################################

Path to directory containing configuration (this file and logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be striped

across

the locations (a la RAID 0) on a file level, favouring locations with

most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:

Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at :
http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to
the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of
the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would still
start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the
cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I
mean that your modifications in elasticsearch.yml are probably not read as
a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each
directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and
make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch
is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I just test that on 0.20.4 and have no problem moving dir.
Perhaps you should log in DEBUG?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 18:22, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

#################################### Paths ####################################

Path to directory containing configuration (this file and logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be striped across

the locations (a la RAID 0) on a file level, favouring locations with most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:
Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at : http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:
graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I mean that your modifications in elasticsearch.yml are probably not read as a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each directory over ending up with

/bigdata/elasticsearch/data/graylog2 and /bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:
On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data directory to a new directory ? Can I simple 'cp /old/data /new/data' without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Let me figure out how to do that and I'll get back to you with the results.

Thanks for the help so far though.

-barrett

On Tue, Feb 19, 2013 at 12:27 PM, David Pilato david@pilato.fr wrote:

I just test that on 0.20.4 and have no problem moving dir.
Perhaps you should log in DEBUG?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:22, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

#################################### Paths
####################################

Path to directory containing configuration (this file and logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be

striped across

the locations (a la RAID 0) on a file level, favouring locations with

most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:

Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at :
http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to
the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of
the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would
still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the
cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I
mean that your modifications in elasticsearch.yml are probably not read as
a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each
directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch
and make the chmod.

In my elasticsearch.yml I pointed path.data to
/bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in
/var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

The level was already set at DEBUG in my logging.yml

On Tue, Feb 19, 2013 at 12:28 PM, j.barrett strausser <
j.barrett.strausser@gmail.com> wrote:

Let me figure out how to do that and I'll get back to you with the results.

Thanks for the help so far though.

-barrett

On Tue, Feb 19, 2013 at 12:27 PM, David Pilato david@pilato.fr wrote:

I just test that on 0.20.4 and have no problem moving dir.
Perhaps you should log in DEBUG?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:22, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

#################################### Paths
####################################

Path to directory containing configuration (this file and logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be

striped across

the locations (a la RAID 0) on a file level, favouring locations with

most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:

Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at :
http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to
the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of
the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would
still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the
cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I
mean that your modifications in elasticsearch.yml are probably not read as
a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each
directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch
and make the chmod.

In my elasticsearch.yml I pointed path.data to
/bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in
/var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Can Gist your logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 18:43, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

The level was already set at DEBUG in my logging.yml

On Tue, Feb 19, 2013 at 12:28 PM, j.barrett strausser j.barrett.strausser@gmail.com wrote:
Let me figure out how to do that and I'll get back to you with the results.

Thanks for the help so far though.

-barrett

On Tue, Feb 19, 2013 at 12:27 PM, David Pilato david@pilato.fr wrote:
I just test that on 0.20.4 and have no problem moving dir.
Perhaps you should log in DEBUG?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 18:22, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

#################################### Paths ####################################

Path to directory containing configuration (this file and logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be striped across

the locations (a la RAID 0) on a file level, favouring locations with most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:
Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at : http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:
graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?). I mean that your modifications in elasticsearch.yml are probably not read as a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" j.barrett.strausser@gmail.com a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each directory over ending up with

/bigdata/elasticsearch/data/graylog2 and /bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch and make the chmod.

In my elasticsearch.yml I pointed path.data to /bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in /var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:
On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data directory to a new directory ? Can I simple 'cp /old/data /new/data' without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

That is the log from a successful start, meaning ; I had my "new" data
path commented out.
Uncommenting the new data path results in no logs being put in the file.

On Tue, Feb 19, 2013 at 12:50 PM, David Pilato david@pilato.fr wrote:

Can Gist your logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:43, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

The level was already set at DEBUG in my logging.yml

On Tue, Feb 19, 2013 at 12:28 PM, j.barrett strausser <
j.barrett.strausser@gmail.com> wrote:

Let me figure out how to do that and I'll get back to you with the
results.

Thanks for the help so far though.

-barrett

On Tue, Feb 19, 2013 at 12:27 PM, David Pilato david@pilato.fr wrote:

I just test that on 0.20.4 and have no problem moving dir.
Perhaps you should log in DEBUG?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:22, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

#################################### Paths
####################################

Path to directory containing configuration (this file and logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be

striped across

the locations (a la RAID 0) on a file level, favouring locations with

most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:

Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at :
http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data to
the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid of
the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would
still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.fr wrote:

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the
cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?).
I mean that your modifications in elasticsearch.yml are probably not read
as a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied each
directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch
and make the chmod.

In my elasticsearch.yml I pointed path.data to
/bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in
/var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.fr wrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current data
directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

:frowning:

Turned out to be a whitespace issue in my elastisearch.yaml.

I wish it had been easier to locate this issue.

In any case, I ended up doing the following in /etc/init.d/elasticsearch

On the start-stop-daemon command I modified the following

original :

--exec /bin/bash -- -c "$DAEMON $DAEMON_ARGS"

modified:

--exec /bin/bash -- -c "$DAEMON $DAEMON_ARGS >
/var/log/elasticsearch/startup.log 2>&1"

I then saw the following error :

Setup Failed ...

  • SettingsException[Failed to load settings from
    [file:/etc/elasticsearch/elasticsearch.yml]]
    ParserException[while parsing a block mapping; expected , but found BlockMappingStart]

which I recognized as a yaml error.

-barrett

On Tue, Feb 19, 2013 at 2:15 PM, j.barrett strausser <
j.barrett.strausser@gmail.com> wrote:

That is the log from a successful start, meaning ; I had my "new" data
path commented out.
Uncommenting the new data path results in no logs being put in the file.

https://github.com/bstrausser/elasticsearchdebug/blob/master/graylog2.log

On Tue, Feb 19, 2013 at 12:50 PM, David Pilato david@pilato.fr wrote:

Can Gist your logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:43, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

The level was already set at DEBUG in my logging.yml

On Tue, Feb 19, 2013 at 12:28 PM, j.barrett strausser <
j.barrett.strausser@gmail.com> wrote:

Let me figure out how to do that and I'll get back to you with the
results.

Thanks for the help so far though.

-barrett

On Tue, Feb 19, 2013 at 12:27 PM, David Pilato david@pilato.fr wrote:

I just test that on 0.20.4 and have no problem moving dir.
Perhaps you should log in DEBUG?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:22, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

#################################### Paths
####################################

Path to directory containing configuration (this file and

logging.yml):

path.conf: /path/to/conf

Path to directory where to store index data allocated for this node.

path.data: /bigdata/elasticsearch/data

Can optionally include more than one location, causing data to be

striped across

the locations (a la RAID 0) on a file level, favouring locations with

most free

space on creation. For example:

path.data: /path/to/data1,/path/to/data2

Path to temporary files:

path.work: /path/to/work

Path to log files:

path.logs: /bigdata/elasticsearch/log

Path to where plugins are installed:

path.plugins: /path/to/plugins

Running ls -la on /bigdata/elasticsearch/data gives

drwxrwxr-x 4 elasticsearch elasticsearch 4096 Feb 19 11:14 data

On Tue, Feb 19, 2013 at 12:12 PM, David Pilato david@pilato.fr wrote:

Can you paste here your path*** lines ?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 18:09, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

For the record I am on

Ubunutu 12.10 running the deb found at :
http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.4.deb
I had no issues starting or indexing prior to changing the path.data
to the new path. If I comment it out (revert to default) ES starts up again.

Correct on the first question. I realize I could essentially get rid
of the elasticsearch directory inside of /data

I don't see any output in /var/log/elasticsearch.

I am starting ES via /etc/init.d/elasticsearch start

If it wasn't respecting the paths in the .yml then I assume it would
still start as it should use the default paramaters.

-b

On Tue, Feb 19, 2013 at 11:59 AM, David Pilato david@pilato.frwrote:

graylog2 and elasticsearch dirs are relative to cluster names.

I think you first started a cluster using defaults and then move the
cluster name to graylog2, don't you?

That said, what does logs are telling?
How did you start Elasticsearch?

Are you sure that path are not set externally (in a launch script ?).
I mean that your modifications in elasticsearch.yml are probably not read
as a script already defines paths.

Does it help?

--
David Pilato | Technical Advocate | *Elasticsearch.comhttp://elasticsearch.com/
*
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 19 févr. 2013 à 17:49, "j.barrett strausser" <
j.barrett.strausser@gmail.com> a écrit :

Bit of a snag

My data directory was previously ( I assume it was at least)

/var/lib/elasticsearch with

../graylog2
../elasticsearch

being the child items

I wanted to move them to /bigdata/elasticsearch/data so I copied
each directory over ending up with

/bigdata/elasticsearch/data/graylog2 and
/bigdata/elasticsearch/data/elasticsearch

I then chowned /big/data/elasticsearch to elasticsearch:elasticsearch
and make the chmod.

In my elasticsearch.yml I pointed path.data to
/bigdata/elasticsearch/data

Running /etc/init.d/elasticsearch results in a failed start.

I'm sure I messed something trivial up. Nothing in
/var/log/elasticsearch is being helpful though.

-barrett

On Tue, Feb 19, 2013 at 1:27 AM, David Pilato david@pilato.frwrote:

On a stopped Elasticsearch node, yes.

You can test it on a test cluster.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 févr. 2013 à 06:22, j.barrett.strausser@gmail.com a écrit :

Apologies for the simple question.

What would be the procedure for moving the data from the current
data directory to a new directory ? Can I simple 'cp /old/data /new/data'
without worrying about corruption someplace?

Is the only configuration point really

path:
logs: /var/log/elasticsearch
data: /var/data/elasticsearch

Thanks

-b

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--

https://github.com/bearrito
@barrettsmash

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--

https://github.com/bearrito
@barrettsmash

--


@barrettsmash

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.