Native authentication showing up even if it is disabled

Hi guys,

I currently have an ELK stack running with x-pack installed on both Elasticsearch and Kibana. My elasticsearch.yml config looks a bit like this:

xpack.graph.enabled: false false
xpack.monitoring.enabled: false
#xpack.reporting.enabled: false
xpack.watcher.enabled: false true true false
#defining realm chain
  type: custom
  order: 0
  enabled: true
   admin_roles: superuser
   default_roles: audit_read

Authentication of the custom realm seems to work nicely however, after authenticating my user via my custom x-pack plugin, Kibana will display the U/P basic form. What is the proper way to fully disable it? Or is it the way I do my custom authentication that makes it show up?

Thanks in advance.

Hi @g-vamp,

It sounds very similar to what had been discussed here: Disable login in Kibana 5.3.

In short, there are only 2 main possibilities to bypass Kibana login screen at the moment:

  • Disable security entirely, likely it's not an option for you;
  • Attribute your every request with proper Authorization: Basic *** HTTP header (if your realm supports Basic authentication of course). See the post above that explains how to do that with the help of reverse proxy.

Let me know if you still have questions.


Hi Oleg, thanks for your help, this does the trick!

I need both native and custom realm auth. But native auth is only needed as fall back when Kibana is not accessed via the proxy (i.e. via a vpn), in which case I want it enabled. With the proxy config trick it will just work nicely.

Thanks again.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.