Need help with creating index pattern for .txt log files

i have installed elastic search and configured it in RHEL, installed kibana as well.
Elasticsearch: elasticsearch-6.7.0
Kibana: kibana-6.7.0-linux-x86_64

both are in running state, ports 5061(kibana) and 9200(elasticsearch) are listening,
able to access kibana dashboard.
problem is when i open dashboard it says "Cannot connect to the Elasticsearch cluster currently configured for Kibana. To use the full set of free features in this distribution of Kibana, please update Elasticsearch to the default distribution."

<<<< kibana.yml >>>

Kibana is served by a back end server. This setting specifies the port to use.

server.port: 5601 "
server.basePath: ""
server.rewriteBasePath: false
server.maxPayloadBytes: 1048576 "$HOSTNAME"
elasticsearch.preserveHost: true
kibana.index: ".kibana"
kibana.defaultAppId: "home"
elasticsearch.username: ""
elasticsearch.password: ""
server.ssl.enabled: false

<<<< elasticsearch.yml >>> /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
http.port: 9200
bootstrap.system_call_filter: false

Note: i have used .tar.gz package for instillation of both E&K
can anyone help me with this, deployed both in single node.

Kibana 6.7.0 will fail to start up if you use:

elasticsearch.username: ""
elasticsearch.password: ""

Try removing these settings.

Thanks @thiago i will try it

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.