Need help with pfx certificate installation on Windows Server 2016

Hi All,

Any help would be appreciated!

I have downloaded latest 8.1.2 Elasticsearch version on my windows Server 2016 (.zip file). After extracting it, I tried creating certificates by following below two commands without specifying any password.
.\Elasticsearch-certutil ca
.\Elasticsearch-certutil cert --ca elastic-stack-ca.p12
It created elastic-stack-ca & elastic-certificates certificates.
When I tried to install elastic-certificates certificate by using Install PFX -> under Local Machine, then it gave me "The password you entered is incorrect." error on Private key protection step.
I have tried with password as well but it didn't work out.

If I follow same steps on my another Windows machine having Windows 10 or Windows Server 2019 OS then I am able to install elastic-certificates certificate without any error.

Is there any specific reason it is not working with Windows Server 2016?

Any help would be really useful.
Note: I tried with Elasticsearch 7.17 version as well and it gave me same above behavior.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.