NEST, can't disable indenting

This is my code:

var connectionSettings = new ConnectionSettings(new
connectionSettings.SetJsonSerializerSettingsModifier(settings =>
settings.Formatting = Formatting.None;
var nestClient = new ElasticClient(connectionSettings);

I previously used ElasticSearch.NET directly, and I had no problem setting
formatting to "Formatting.None", but when using NEST, whenever I index a
document, it's indented. This is an example of an Index call:

nestClient.Index(obj, i => i.Index(index).Type("user").Id(key));

Thanks for helping me out here!


You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit