New install can't access http port 9200


(Kevin Pearce) #1

I am doing my first ever install of elastic search and I appear to have hit an issue right out of the gate. I can't seem to get to http://:9200 from a browser. I performed an rpm install of version 5.4 on my CentOS 7 vm and the only config change I have made so far is to set the network.host to my IP. It appears that ES is running based on:

[root@supelk elasticsearch]# curl -XGET '10.2.22.169:9200/_cat/health?v&pretty'
epoch timestamp cluster status node.total node.data shards pri relo init unassign pending_tasks max_task_wait_time active_shards_percent
1495028823 08:47:03 elasticsearch green 1 1 0 0 0 0 0 0 - 100.0%
[root@supelk elasticsearch]#

and I believe the host is seeing traffic because when I try to connect from a browser, this is what see on a tcpdump:

[root@supelk elasticsearch]# tcpdump -i ens160 tcp port 9200
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ens160, link-type EN10MB (Ethernet), capture size 65535 bytes
08:48:57.528125 IP 10.2.19.16.50512 > supelk.wap-wsp: Flags [SEW], seq 3052757200, win 65535, options [mss 1348,nop,wscale 5,nop,nop,TS val 1127708011 ecr 0,sackOK,eol], length 0
08:48:57.529082 IP 10.2.19.16.50513 > supelk.wap-wsp: Flags [S], seq 1001362015, win 65535, options [mss 1348,nop,wscale 5,nop,nop,TS val 1127708011 ecr 0,sackOK,eol], length 0

Have I missed something obvious here? Any help would be greatly appreciated.


#2

I am installing 5.4 today and I see the same issue. Port 9200 is active when I set network.host: localhost
But, when I set network.host: , I see curl: (7) Failed to connect to port 9200: Connection refused.

Can someone explain what's going on here? I have installed 5.3 very recently but never faced this kind of issue.


#3

Also running into this with ES 5.4 on Ubuntu 16.04.

elasticsearch service is running, however netstat -l does not show 9200 listening


#4

Guys,

Please let me know if you figure out a way out of this.
@dadoonet could you please look into this issue?


(Kevin Pearce) #5

Turns out all I had to do to get out of this was turn off iptables firewall.

iptables -F

and now I can get the page.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.