Newbie issue


(Matan Safriel) #1

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem to think I won't be
needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the ser
ver vm for best performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--


(Ivan Brusic) #2

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release? I
believe that that error message is only for 32-bit JVMs, but I could be
wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel matan@cloudaloe.org wrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem to think I won't be
needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the ser
ver vm for best performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--


(Matan Safriel) #3

It's a 32-bit server and JVM:

$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4)
(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

Does that warning (WARN) message indicate it is reason not to start
elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release? I
believe that that error message is only for 32-bit JVMs, but I could be
wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel <ma...@cloudaloe.org<javascript:>

wrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem to think I won't be
needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the server vm for best
performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--


(Ivan Brusic) #4

I have not used a 32-bit JVM in a while, but from what I remember, it
should only be a warning. ElasticSearch should still start.

You can add the -server flag directly to the startup script (
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
) or you can set it using JAVA_OPTS (untested).

$ JAVA_OPTS="-server"
$ sudo bin/elasticsearch -f

Ivan

On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel matan@cloudaloe.org wrote:

It's a 32-bit server and JVM:

$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4)
(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

Does that warning (WARN) message indicate it is reason not to start
elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release? I
believe that that error message is only for 32-bit JVMs, but I could be
wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel ma...@cloudaloe.orgwrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem to think I won't be
needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the server vm for best
performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--

--


(David Pilato) #5

Yes. It's only a warn. ES should start. Did you modify any setting? Memory, Elasticsearch.yml?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 oct. 2012 à 23:59, Ivan Brusic ivan@brusic.com a écrit :

I have not used a 32-bit JVM in a while, but from what I remember, it should only be a warning. ElasticSearch should still start.

You can add the -server flag directly to the startup script ( https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122 ) or you can set it using JAVA_OPTS (untested).

$ JAVA_OPTS="-server"
$ sudo bin/elasticsearch -f

Ivan

On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel matan@cloudaloe.org wrote:

It's a 32-bit server and JVM:

$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

Does that warning (WARN) message indicate it is reason not to start elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release? I believe that that error message is only for 32-bit JVMs, but I could be wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel ma...@cloudaloe.org wrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the suggested flow.
I skipped the discovery and gateway stuff, as I seem to think I won't be needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the client vm, make sure to run java with the server vm for best performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--

--


(Matan Safriel) #6

Well, JAVA_OPTS="-server" made no difference... won't be going for a source
code change.
Yes, I changed the configuration compared to the default:

  • cluster.name: myname
  • bootstrap.mlockall: true
  • gateway.recover_after_nodes: 1

And memory as environment variables (its an EC2 mini instance with 600mb).

  • ES_MAX_MEM=300mb
  • ES_MIN_MEM=300mb
  • Also tried increasing to 500mb

In the logging configuration:

  • com.amazonaws: WARN
  • org.apache: WARN

Even when I change them to DEBUG, I get no feedback in the logs. How should
I increase logging, to see what's going on?
Is it at all possible to run ES on an EC2 mini instance linux AMI?

Matan

On Wednesday, October 3, 2012 3:15:11 AM UTC+2, David Pilato wrote:

Yes. It's only a warn. ES should start. Did you modify any setting?
Memory, Elasticsearch.yml?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 oct. 2012 à 23:59, Ivan Brusic <iv...@brusic.com <javascript:>> a
écrit :

I have not used a 32-bit JVM in a while, but from what I remember, it
should only be a warning. ElasticSearch should still start.

You can add the -server flag directly to the startup script (
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
) or you can set it using JAVA_OPTS (untested).

$ JAVA_OPTS="-server"
$ sudo bin/elasticsearch -f

Ivan

On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel <ma...@cloudaloe.org<javascript:>

wrote:

It's a 32-bit server and JVM:

$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4)
(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

Does that warning (WARN) message indicate it is reason not to start
elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release?
I believe that that error message is only for 32-bit JVMs, but I could be
wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel ma...@cloudaloe.orgwrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem to think I won't
be needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses
the client vm, make sure to run java with the server vm for best
performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--

--

--


(David Pilato) #7

I think that you should set ES_MAX_MEM=300m and not 300mb
Same for ES_MIN_MEM

HTH
David.

Le 3 octobre 2012 à 09:38, Matan Safriel matan@cloudaloe.org a écrit :

Well, JAVA_OPTS="-server" made no difference... won't be going for a source
code change.
Yes, I changed the configuration compared to the default:
* cluster.name: myname
* bootstrap.mlockall: true
* gateway.recover_after_nodes: 1
And memory as environment variables (its an EC2 mini instance with 600mb).
* ES_MAX_MEM=300mb
* ES_MIN_MEM=300mb
* Also tried increasing to 500mb
In the logging configuration:
* com.amazonaws: WARN
* org.apache: WARN
Even when I change them to DEBUG, I get no feedback in the logs. How should I
increase logging, to see what's going on?
Is it at all possible to run ES on an EC2 mini instance linux AMI?

Matan

On Wednesday, October 3, 2012 3:15:11 AM UTC+2, David Pilato wrote:

Yes. It's only a warn. ES should start. Did you modify any setting?
Memory, Elasticsearch.yml?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 oct. 2012 à 23:59, Ivan Brusic < iv...@brusic.com> a écrit :

I have not used a 32-bit JVM in a while, but from what I remember, it
should only be a warning. ElasticSearch should still start.

You can add the -server flag directly to the startup script (
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
) or you can set it using JAVA_OPTS (untested).
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122

$ JAVA_OPTS="-server"
$ sudo bin/elasticsearch -f

Ivan

https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel <
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
ma...@cloudaloe.org> wrote:
> > > It's a 32-bit server and JVM:

 $ java -version
 java version "1.6.0_24"
 OpenJDK Runtime Environment (IcedTea6 1.11.4)

(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

 Does that warning (WARN) message indicate it is reason not to start

elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

 On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:
   > > > >        Which JVM are you running? 32-bit or 64-bit? OpenJDK
   > > > > or Oracle release? I believe that that error message is
   > > > > only for 32-bit JVMs, but I could be wrong.
   --
   Ivan

   On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel

ma...@cloudaloe.org wrote:
> > > > > Hi,

     As a newbie to elasticserach I today installed it on EC2, as

per the suggested flow
http://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem to think
I won't be needing that yet or too soon, it's just a single node test
for now.
Didn't quite get what should I do with to fulfill the JVM
configuration comment...

     It seems the server simply won't start.

     $ sudo bin/elasticsearch -f
     [2012-10-02 18:26:32,311][WARN ][bootstrap                ]

jvm uses the client vm, make sure to run java with the ser ver vm
for best performance by adding -server to the command line
$

     Nothing other than this message in the logs.
     My assumptions are probably wrong, or I'm doing something

stupid....

     Please assist.....

     Thanks in advance,
     Matan



     --


   > > > >      > > > 
 --

--

--

--
David Pilato
http://www.scrutmydocs.org/
http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--


(Matan Safriel) #8

Not mentioned, but I tried that too. Also tried sticking to powers of 2..

On Wednesday, October 3, 2012 10:19:28 AM UTC+2, David Pilato wrote:

I think that you should set ES_MAX_MEM=300m and not 300mb
Same for ES_MIN_MEM

HTH
David.

Le 3 octobre 2012 à 09:38, Matan Safriel <ma...@cloudaloe.org<javascript:>>
a écrit :

Well, JAVA_OPTS="-server" made no difference... won't be going for a
source code change.
Yes, I changed the configuration compared to the default:

  • cluster.name: myname
  • bootstrap.mlockall: true
  • gateway.recover_after_nodes: 1

And memory as environment variables (its an EC2 mini instance with
600mb).

  • ES_MAX_MEM=300mb
  • ES_MIN_MEM=300mb
  • Also tried increasing to 500mb

In the logging configuration:

  • com.amazonaws: WARN
  • org.apache: WARN

Even when I change them to DEBUG, I get no feedback in the logs. How
should I increase logging, to see what's going on?
Is it at all possible to run ES on an EC2 mini instance linux AMI?

Matan

On Wednesday, October 3, 2012 3:15:11 AM UTC+2, David Pilato wrote:

Yes. It's only a warn. ES should start. Did you modify any setting?
Memory, Elasticsearch.yml?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 oct. 2012 à 23:59, Ivan Brusic < iv...@brusic.com> a écrit :

I have not used a 32-bit JVM in a while, but from what I remember, it
should only be a warning. ElasticSearch should still start.

You can add the -server flag directly to the startup script ( https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
) or you can set it using JAVA_OPTS (untested).https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122

$ JAVA_OPTS="-server"
$ sudo bin/elasticsearch -f

Ivan

https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel <https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
ma...@cloudaloe.org> wrote:

It's a 32-bit server and JVM:

$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4)
(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

Does that warning (WARN) message indicate it is reason not to start
elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release? I
believe that that error message is only for 32-bit JVMs, but I could be
wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel ma...@cloudaloe.orgwrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html.

I skipped the discovery and gateway stuff, as I seem to think I won't be
needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the ser ver vm for best
performance by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--

--

--

--
David Pilato
http://www.scrutmydocs.org/
http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--


(David Pilato) #9

I'm running an ES instance on a EC2 mini instance.
That's not a problem.

I will try to check my settings later (I don't have access to my instance at
work ;-( ) and post it here.

Unless someone else has an idea in the meantime

Le 3 octobre 2012 à 10:25, Matan matan@cloudaloe.org a écrit :

Not mentioned, but I tried that too. Also tried sticking to powers of 2..

On Wednesday, October 3, 2012 10:19:28 AM UTC+2, David Pilato wrote:

I think that you should set ES_MAX_MEM=300m and not 300mb
Same for ES_MIN_MEM

HTH
David.

Le 3 octobre 2012 à 09:38, Matan Safriel < ma...@cloudaloe.org> a écrit :

> > >     Well, JAVA_OPTS="-server" made no difference... won't be going
> > > for a source code change.
Yes, I changed the configuration compared to the default:
    * cluster.name <http://cluster.name> : myname
    * bootstrap.mlockall: true
    * gateway.recover_after_nodes: 1
And memory as environment variables (its an EC2 mini instance with

600mb).
* ES_MAX_MEM=300mb
* ES_MIN_MEM=300mb
* Also tried increasing to 500mb
In the logging configuration:
* com.amazonaws: WARN
* org.apache: WARN
Even when I change them to DEBUG, I get no feedback in the logs. How
should I increase logging, to see what's going on?
Is it at all possible to run ES on an EC2 mini instance linux AMI?

Matan


On Wednesday, October 3, 2012 3:15:11 AM UTC+2, David Pilato wrote:
  > > > >       Yes. It's only a warn. ES should start. Did you modify
  > > > > any setting? Memory, Elasticsearch.yml?
  --
  David ;-)
  Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs


  Le 2 oct. 2012 à 23:59, Ivan Brusic < iv...@brusic.com> a écrit :
  I have not used a 32-bit JVM in a while, but from what I remember,

it should only be a warning. ElasticSearch should still start.

  You can add the -server flag directly to the startup script (

https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
) or you can set it using JAVA_OPTS (untested).
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122

  $ JAVA_OPTS="-server"
  $ sudo bin/elasticsearch -f

  Ivan

https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122

  <https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122>
  On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel <

https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
ma...@cloudaloe.org> wrote:
> > > > > It's a 32-bit server and JVM:

    $ java -version
    java version "1.6.0_24"
    OpenJDK Runtime Environment (IcedTea6 1.11.4)

(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

    Does that warning (WARN) message indicate it is reason not to

start elasticsearch?
'use -server on the command' is not much more than a puzzle to
me.

    On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic

wrote:
> > > > > > Which JVM are you running? 32-bit or
> > > > > > 64-bit? OpenJDK or Oracle release? I believe
> > > > > > that that error message is only for 32-bit JVMs,
> > > > > > but I could be wrong.

      --
      Ivan

      On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel

ma...@cloudaloe.org wrote:
> > > > > > > Hi,

        As a newbie to elasticserach I today installed it on

EC2, as per the suggested flow
http://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html
.
I skipped the discovery and gateway stuff, as I seem
to think I won't be needing that yet or too soon, it's just a
single node test for now.
Didn't quite get what should I do with to fulfill the
JVM configuration comment...

        It seems the server simply won't start.

        $ sudo bin/elasticsearch -f
        [2012-10-02 18:26:32,311][WARN ][bootstrap
           ] jvm uses the client vm, make sure to run `java`

with the ser ver vm for best performance by adding -server to
the command line
$

        Nothing other than this message in the logs.
        My assumptions are probably wrong, or I'm doing

something stupid....

        Please assist.....

        Thanks in advance,
        Matan



        --


      > > > > > >         > > > > > 
    --


  > > > > 
  --


> > > 
--

--
David Pilato
http://www.scrutmydocs.org/ http://www.scrutmydocs.org/
http://dev.david.pilato.fr/ http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--

--
David Pilato
http://www.scrutmydocs.org/
http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--


(Matan Safriel) #10

Thanks :slight_smile:

Sent from my mobile

On Oct 3, 2012, at 10:32 AM, David Pilato david@pilato.fr wrote:

I'm running an ES instance on a EC2 mini instance.
That's not a problem.

I will try to check my settings later (I don't have access to my instance
at work ;-( ) and post it here.

Unless someone else has an idea in the meantime

Le 3 octobre 2012 à 10:25, Matan matan@cloudaloe.org a écrit :

Not mentioned, but I tried that too. Also tried sticking to powers of 2..

On Wednesday, October 3, 2012 10:19:28 AM UTC+2, David Pilato wrote:

I think that you should set ES_MAX_MEM=300m and not 300mb
Same for ES_MIN_MEM

HTH
David.

Le 3 octobre 2012 à 09:38, Matan Safriel < ma...@cloudaloe.org> a écrit :

Well, JAVA_OPTS="-server" made no difference... won't be going for a
source code change.
Yes, I changed the configuration compared to the default:

  • cluster.name: myname
  • bootstrap.mlockall: true
  • gateway.recover_after_nodes: 1

And memory as environment variables (its an EC2 mini instance with 600mb).

  • ES_MAX_MEM=300mb
  • ES_MIN_MEM=300mb
  • Also tried increasing to 500mb

In the logging configuration:

  • com.amazonaws: WARN
  • org.apache: WARN

Even when I change them to DEBUG, I get no feedback in the logs. How
should I increase logging, to see what's going on?
Is it at all possible to run ES on an EC2 mini instance linux AMI?

Matan

On Wednesday, October 3, 2012 3:15:11 AM UTC+2, David Pilato wrote:

Yes. It's only a warn. ES should start. Did you modify any setting?
Memory, Elasticsearch.yml?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 oct. 2012 à 23:59, Ivan Brusic < iv...@brusic.com> a écrit :
I have not used a 32-bit JVM in a while, but from what I remember, it
should only be a warning. ElasticSearch should still start.

You can add the -server flag directly to the startup script (
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
) or you can set it using JAVA_OPTS
(untested).https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122

$ JAVA_OPTS="-server"
$ sudo bin/elasticsearch -f

Ivan
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
On Tue, Oct 2, 2012 at 2:31 PM, Matan Safriel
<https://github.com/elasticsearch/elasticsearch/blob/master/bin/elasticsearch#L122
ma...@cloudaloe.org> wrote:

It's a 32-bit server and JVM:

$ java -version
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4)
(amazon-52.1.11.4.46.amzn1-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

Does that warning (WARN) message indicate it is reason not to start
elasticsearch?
'use -server on the command' is not much more than a puzzle to me.

On Tuesday, October 2, 2012 8:51:33 PM UTC+2, Ivan Brusic wrote:

Which JVM are you running? 32-bit or 64-bit? OpenJDK or Oracle release? I
believe that that error message is only for 32-bit JVMs, but I could be
wrong.

--
Ivan

On Tue, Oct 2, 2012 at 11:29 AM, Matan Safriel ma...@cloudaloe.orgwrote:

Hi,

As a newbie to elasticserach I today installed it on EC2, as per the
suggested flowhttp://www.elasticsearch.org/tutorials/2011/08/22/elasticsearch-on-ec2.html.

I skipped the discovery and gateway stuff, as I seem to think I won't be
needing that yet or too soon, it's just a single node test for now.
Didn't quite get what should I do with to fulfill the JVM configuration
comment...

It seems the server simply won't start.

$ sudo bin/elasticsearch -f
[2012-10-02 18:26:32,311][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the ser ver vm for best performance
by adding -server to the command line
$

Nothing other than this message in the logs.
My assumptions are probably wrong, or I'm doing something stupid....

Please assist.....

Thanks in advance,
Matan

--

--

--

--

--
David Pilato
http://www.scrutmydocs.org/
http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--

--
David Pilato
http://www.scrutmydocs.org/
http://dev.david.pilato.fr/
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

--

--


(system) #11